Dodge Cummins Diesel Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter #1
So long story short, I've fixed broken wires in all of my door jams, replaced the switch in the driver door, checked the fuses in the TIPM, and just replaced the actuator. When I hit the lock button on the fob or the door switch I hear a click behind my instrument cluster, but nothing is going to the door actuator. All of my doors unlock with the switch and the fob, electric windows, and lights work on all the doors. I'm not 100% sure where to go from here, but from what I'm reading it could also be the instrument cluster, and if it's that I'll take it in, but I'm just not sure where to look next. The TIPM has also been replaced on an unrelated issue, but the doors seem to be unaffected by that.

Thanks for looking
 

·
Registered
Joined
·
42 Posts
Discussion Starter #5
Dodge dealer said the cluster is bad, and they don't male them anymore, and their shop can't repair them. I am seeing repair services for the cluster but no one mentions the lock repair. Do you think I am better off just replacing the whole thing with a used one?
 

·
Premium Member
Joined
·
5,561 Posts
Did they tell you how they diagnosed ie codes??
AFAIK, Cant just replace with good used would need to be programmed for your VIN/milieage, I would google local cluster repair shop see what they can do.
Or if you feeling adventurous can try remove cluster disassemble look for bad solder joints, repair them, which is most common issue.
 

·
Registered
Joined
·
34 Posts
Do you have a multimeter? Do you see any voltage coming from the cluster on the lock circuit(s)? Might want to check before tearing it apart. Could be a bad ground somewhere since you're hearing clicking in the cluster.
 
1 - 7 of 7 Posts
Top