Dodge Cummins Diesel Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Hey guys I've got a 2004 2500 with 98,xxx miles. When I put it into gear it won't do anything like won't rev up when I press on the gas pedal just idles. I cut the engine off came back in 5 mins started it up and acted perfectly fine. Help please!!!!
 

·
Registered
Joined
·
5,649 Posts
did you pull codes?
also how cold out is it?(fuel gelled?)
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #3 ·
I had just gotten out of it. I had just drove it about 100 miles round trip. So Im thinkin the fuel was ok. And I mean 5 mins later it acted fine. And how do I pull the codes?
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #4 ·
I just pulled the codes. Only one that showed up was p0234.
 

·
Registered
Joined
·
47 Posts
I just pulled the codes. Only one that showed up was p0234.
code P0234 = Turbo Boost Limit Exceeded
that should not have anything to do with your rig not moving
 

·
Registered
Joined
·
1,523 Posts
Sounds like an APPS going out.
Some of these trucks use different system for the throttle input, and I have no idea which use what system.
My 03 auto has its APPS on the left side front of the engine. My neighbors 04 w/manual trans does not have anythng located in that same location.
When they start to crap out they tend to randomly give a "dead pedal"/no response to skinny pedal input, then all of a sudden fine again.


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #8 ·
I really appreciate the comments. I will look into that APPS sensor and see if that fixes it. Thanks again guys!
 

·
Registered
Joined
·
63 Posts
I had that happen 2 times, then found out that my quadzilla wiring harness was causing the issue. Removed quad, got a smarty tuner and hasn't happened again. Thought i would mention this if you have a quad. Fill out your sig. So we can see if your stock or what is done to your truck.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #10 ·
I appreciate man, and I have a smart s06 on it. And I just did the signature thing.
It's acted fine today.
 

·
Registered
Joined
·
7,291 Posts
check connections to ecm c1 connector , iat sensor and FCA connector
bad connections can cause p0234 code, iat shares signal/power with turbo boost pressure sensor and also FCA circuit ie fuel pump driver , fuel rail pressure return signal.
 

·
Registered
Joined
·
47 Posts
check connections to ecm c1 connector , iat sensor and FCA connector

bad connections can cause p0234 code, iat shares signal/power with turbo boost pressure sensor and also FCA circuit ie fuel pump driver , fuel rail pressure return signal.

Were is the iat sensor and fca circuit located and which one is the c1 connector
thanks Gary



Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
311 Posts
if you do decide to get a apps get timbo apps half the price of oem and for the more indistrial engines. great guy he helped me install mine. 165$
 
1 - 14 of 14 Posts
Top