Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 12 of 12 Posts

·
Registered
Joined
·
118 Posts
Discussion Starter #1
I got a 2004 with 356k on it now its starting to act up. Sometimes it surges on take off, other times it willl pop randomly at idle. Any ideas? It doesn't do it at speed, just at low rpms.
KInda reminds me or whem the vp44 went out on the 99 model but theres no puff of smoke. Oh, motor is stock... never been chipped. Thanks, for any ideas.
 

·
Registered
Joined
·
38 Posts
Mine was doing that at 1500/1799 rpms after i installed the air dog. I think i solved the problem yesterday. It was getting air in the system. If you have the stock in-tank fuel lift pump you need to check your fuel pressure. Also the o-ring around the top of your fuel filter can could be nicked and letting air in and with low to no fuel pressure from the lift pump you could be getting air into the system.
 

·
Registered
Joined
·
793 Posts
im thinkin with buck because of the mileage.
 

·
Registered
Joined
·
118 Posts
Discussion Starter #6
Went to the dealer this morning. Did a complete fuel system check. Good pressure from lift pump, injector pump and all injectors were functioning correctly. They updated the software too. Left the place and did it again not a block away. Took it back and cleaned the massair sensor( damn k&n). Did it once again but seems to have stopped. I'm thinking the crankshaft position sensor may be on the fritz. Oh, no codes at all came up.
 

·
Registered
Joined
·
118 Posts
Discussion Starter #8
Problem subsided for a couple of days and started back, except for this time it died when i pushed the clutch in. Did it twice this week, everything is still happening at low rpm( below 1100). Still isnt showing any codes. Any ideas? Oh, truck started back with no problems.
 

·
Registered
Joined
·
129 Posts
Mine would buck and die ran good at high rpms.I was pullin with mine as long as I did not stop it would go fine.It was my lift pump going out. Could be the ground from the bed to the tank.It's just getting worse on you.When you hit a bump or something making it loose the ground.I'd check that to see if that was my problem.
 

·
Registered
Joined
·
118 Posts
Discussion Starter #10
Thanks for the input. I'll check as soon as I can. Could you tell a difference with the FASS system over stock? and the boost fooler-- how does that work and did uit work well? Thanks again
 

·
Registered
Joined
·
129 Posts
I could really tell a difference.IT works good together,You drive it so long with it getting weak then you get the fuel pressure back up you can fell the difference.The stock lift pump will keep up with the truck stock then you put a chip in it,It goes south you gas on it fuel pressure goes into the - pressure. Because the lift pump can not keep up with the fuel demand.The it starts getting weak on you.
 

·
Registered
Joined
·
118 Posts
Discussion Starter #12
Still doing it kinda like dead pedal. Do you think it could be the FCA or the APPS?
 
1 - 12 of 12 Posts
Top