Dodge Cummins Diesel Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hello,
I have just purchased this truck from a friend and I knew how much he looked after it. I am having problems with the cruise control. When switched on it displays o.k. on the dash. First time you select "cruise" it only works for a very short period then shuts off. After that it will not re-activate until engine is restarted and the whole thing happens again.
I am not sure if it would make a difference but the front end and brakes were rebuild before i picked it up. My friend is sure it was working the last time he drove it.
Another problem is although the radio works fine the 6 change C.D. unit is not working. I would appreciate any help with these problems.
 

·
Registered
Joined
·
3,151 Posts
Under the hood just below the master cylinder is where the throttle cable and cruise control cable cross eachother. The vacuum line going to the CC servo passes through this crossing and rubs a hole in the vacuum line. Check that first. This is all assuming you have an auto trasmission. Manuals use fly by wire.
 

·
Registered
Joined
·
1,498 Posts
Thanks for the tip. I will check that out.


if thats not it, try the 3rd gen section where you will get more looks and therefore more help.
but 03 did have the same problem, was the vac line got melted (twin turbo truck) replaced the line all was good again.
 
  • Like
Reactions: EricJB

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
Hello, Just wanted to say thanks for the info. The problem was a vacuum line that had been disconnected when the Airbag compressor was being replaced. A nice simple fix and very easy on the pocket book. Thanks again
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top