Dodge Cummins Diesel Forum banner

1 - 4 of 4 Posts

·
Snake Oil Manufacturer
Joined
·
375 Posts
Discussion Starter #1
I've got a early 2003 with the 47, not the 48. And when i started it up to drive home 30 minutes and put it in Drive, it would not shift out of 1st. I got it home at a whopping 25 mph. Then at home, I turned it off then put it back into drive, this time it acted like it was in 3rd and had to spin 2000 rpms to get it to roll. however, without turning it off I put it in R, then back to D and it works like a champ, until I stopped again then it went back to the stuck in 1st business.

Has anyone ever heard of this? and can offer any advise?

also, this is a 225k mile truck. I do not know if it has ever had a new tranny, never chipped but did pull trailers. I personally dropped the pan 8k miles ago and filled it up with O'reilly's brand ATF+4
 

·
Registered
Joined
·
1,754 Posts
My want to see if you have codes.. Do the key trick and see if you get P0700 code, if yes then you probably have some electrical issues
 

·
Snake Oil Manufacturer
Joined
·
375 Posts
Discussion Starter #4
Just found this old topic of mine. Turned out my heat exchanger went bad and started exchanging tranny fluid and coolant. So my coolant system was pepto pink and my tranny was full of water. Got it rebuilt locally for less than 1400. Then bypass the heat exchanger and removed it from the block. Took $10 in rubber hose for the coolant hoses and a $20 pressure fitting for the tranny lines


Sent from my Autoguide iPhone app
 
1 - 4 of 4 Posts
Top