Dodge Cummins Diesel Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
222 Posts
Discussion Starter #1
This is for more curiosity now but I just traded a 2001 Ram 3500 2wd Manuel 5.9 for my 2007 2500 4wd. Anyway prior to making my trade My 01 was experinceing a severe power loss and was blowing ALOT of white smoke. It was giving off a deisel odor and would not run correct unless I got it up to running temp and in the end it wouldn't even run right then. I would lose all power and the truck would barely run but I could cut the ignition let it coast a second and then restart and it would run normal for about 30 seconds or so.
I though I got a tank of bad fuel so I ran it almost empty, changed the fuel filter, added some Deisel 911, then refilled but didn't change anything. So my question is what do you guys think the problem may have been and this is almost all speculation because the truck is gone so the world may never know. I was thinking maybe clogged injectors or bad injectors.

What do the experts think?
 

·
Mopar1973Man.Com
Joined
·
26,302 Posts
(Looking at my crystal ball)

Your VP44 is shot...

1. Check for error codes I bet money there is a P0216.
OBD II Error Codes

2. You don't have a fuel pressure gauge.
Gauges

3. How much fuel pressure do you have from your lift pump at WOT?
Lift Pump Diagnostics

Sorry to say but VP44 are at least $1,200 then a good lift pump is about $450 to $500 bucks.
 

·
Registered
Joined
·
222 Posts
Discussion Starter #3
Well than I'd say I made out pretty good. That poor 01 had the Air conditioner bypassed because the compressor was locked up and the Condensor was leaking, it had a fair ammount of body damage, and it had the fuel delivery issues. Blue Book Trade in value was only $10,000 and the dealership gave me $8500!
 

·
Registered
Joined
·
55 Posts
Same thing happend to me with my 02 cummins and it was the vp44
 
1 - 4 of 4 Posts
Top