Dodge Cummins Diesel Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
213 Posts
Discussion Starter #1
Alright guys, I am stumped on this issue. Let me explain everything, but first, yes I have read just about everything possible.
Motor recently replaced 6k mikes ago, completely rebuilt, VP is new, Airdog 165 is new, injectors new, everything. I was hauling a load of tools to a rig in south Texas and my check engine light came on. Truck wouldn’t boost past 10psi and then would just boost like crazy and go. Did it the whole way home where I had like a dead pedal and then would pick up. Codes led me to change the MAP sensor. Did that, and light went off and ran normal. It still has a surge or seems like loss of pedal in 1st thru 4th where it feels like it hesitates and then will go. Not really in 5th and 6th but maybe RPM are too high to tell.
When I start it in the morning it is really noticeable until it is warmed up.
I’ve done the ACC thing, cleaned all the terminals, checked all the connections and kind of stumped on what to do next. Could it be the cam shaft sensor? Or a weak battery? Let me know what you guys think. I’m selling the truck to a buddy and want to try and get it figured out for him.
 

·
Registered
Joined
·
295 Posts
Not sure what an ACC thing is, but what kind of fuel pressure you got? Could you possibly have dirty fuel and or filter? Batteries are easy enough to test. Cam sensor usually will set a code. Do you have any new codes? Check with a scan tool.
 

·
Registered
Joined
·
213 Posts
Discussion Starter #3
Not sure what an ACC thing is, but what kind of fuel pressure you got? Could you possibly have dirty fuel and or filter? Batteries are easy enough to test. Cam sensor usually will set a code. Do you have any new codes? Check with a scan tool.
JRoss, no new codes. I’ve checked with my scanner and the key. I meant to say the APPS sensor you calibrate lol! College football was in my head I guess! So I’ve calibrated the accelerator pedal and all that. Fuel filters aren’t but a week or two old. I change those every 4K miles with the oil
 

·
Premium Member
Joined
·
348 Posts
You don't mention fuel pressure or a full time FP gauge.
That's something you and your buddy are both going to want even with the Air dog.
 

·
Registered
Joined
·
213 Posts
Discussion Starter #6
You don't mention fuel pressure or a full time FP gauge.
That's something you and your buddy are both going to want even with the Air dog.
Fuel pressure is 14-16 psi depending on what I’m pulling. Idle it’s bouncing between 16-17 psi. Sorry forgot to mention that. Pressure is good on fuel pressure.

Defuel I would expect to see at a higher rpm. Not at 1300/1400 when just putting around. I could be wrong. But fuel system is all new
 
1 - 6 of 6 Posts
Top