Dodge Cummins Diesel Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter #1
07 2500 with a goerend built in 2011 with 120,000 miles on it now. Btw I do drive it a little hard. The past 2 weeks it seem like a little slow to Shift Maybe it was just me. I was slowing down at a red light got to 5-8 mph. I think it Went to 1st but I heard something and felt something. Like turns green hit the gas little bit some is not right its slipping. I was on my way home 5 miles from home only had to stop 2 times. Yes it's definitely slipping now. I'm draining it right now has a little color to it does not smell burnt. What do I do I'm guessing this a full rebuild probably? It's slipping in drive,2 and 1. It's not slipping in reverse.
 

·
Registered
Joined
·
32 Posts
Discussion Starter #3
OK the pan is off. Filter was a little loose. The 3.8 lever I can Pinkie pull 1/2"and it's easily?
 

·
Premium Member
Joined
·
5,710 Posts
put new filter(35 in/lbs) fluid, adjust bands
try it , 120k hard miles could be worn clutch(rear) issue.
 

·
Registered
Joined
·
1,688 Posts
It sounds like you're losing the forward clutch. The band is not used in first gear, and 1/2" at the lever is a little loose, but not enough to prevent it from working. It's never a bad idea to adjust your bands and change your filter. I'm just not sure it's going to fix anything for you.
 

·
Registered
Joined
·
32 Posts
Discussion Starter #6
Yeah figured you are right still slipping. Question is what broke that made it slip?
 

·
Premium Member
Joined
·
5,710 Posts
Could just be worn out, what are pressures?

If you were sucking air into trans(loose filter) could cause a lot of issues.
 
1 - 7 of 7 Posts
Top