Dodge Cummins Diesel Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
41 Posts
Discussion Starter #1
Hey guys im new on here but i have a 1999 dodge 2500 ext cab long bed auto tranny. 345,000 miles and still runs strong i picked the truck up for 5500$ it has a newer vp and also some trnny work. But my problem is that when in park or neutrual or even when the motor has no strain it idles with a dead miss and sometimes does a sort of lope with no smoke. But when the motor is cold in the morning it idles around 900 rpm and runs smooth but as soon as it warms up the miss is back. Ive heard alot from the vp going bad to a bad lift pump (which is a stock pump) to an injector going bad. Any helpwould be great thanks
 

·
Registered
Joined
·
41 Posts
Discussion Starter #2
Can no one offer advice? I see other threads blowing up with comments....
 

·
Registered
Joined
·
41 Posts
Discussion Starter #4
No i havent yet im trying to locate a good pressure tester
 

·
Mopar1973Man.Com
Joined
·
26,302 Posts
No i havent yet im trying to locate a good pressure tester
Go right to Vulcan Performance. Long enough hose you can keep it in thew cab so you can drive test the truck. Provided to screw right to the schrader valve on the VP44. I got a few extra fitting for test wider range of vehicles.


 

·
Registered
Joined
·
41 Posts
Discussion Starter #6
Thanks will look into that pressure gauge. But back to my issue i put a laser temperature gauge and tested each port on the exhaust manifold. When the rough idle occured cylinder 6 was burning 30-40 cooler than the rest. Can this really pin point that its injectors? Theres no blow by whatsoever so its not a compression issue
 

·
Registered
Joined
·
14,830 Posts
As suggested, scan for codes first. Check for fuel pressure second. Third, if you think the number 6 cylinder has potentially a bad injector then you can try loosening the injector line nut at the head while the engine is running and see if it changes the idle condition. But BE CAREFUL as you're messing with extremely high fuel pressure lines and you dont want to get your fingers in the way of any fuel spray.

But in regards to the injector, usually a bad injector will either cause excessive exhaust haze or smoking. :thumbsup:
 

·
Registered
Joined
·
41 Posts
Discussion Starter #8
Ok but could a bad lift pump really cause it to be a rough idle/miss? Theres no real loss of power that i can tell. But saying that i am coming from an 01 CTD H.O 6 speed with edge comp box haha
 

·
Mopar1973Man.Com
Joined
·
26,302 Posts
No. Because if the lift pump was weak it would get worse under load typically.

If you suspect the injector I would pull the out and have them pop tested. Most shops pop test for free but charge a mild fee for re-tuning. Like I got a local shop its $9 bucks an injector to be re-tuned.
 

·
Registered
Joined
·
14,830 Posts
Ok but could a bad lift pump really cause it to be a rough idle/miss? Theres no real loss of power that i can tell. But saying that i am coming from an 01 CTD H.O 6 speed with edge comp box haha
Mikes correct in saying that low fuel pressure wont directly cause a rough idle.....but it will tell you what condition the VP is in, which can. :thumbsup:
 

·
Registered
Joined
·
41 Posts
Discussion Starter #11
But yesterday i dicovered #6 cylinder is running 30-40 degrees cooler than the rest at the manifold port. Not saying yall are incorrect but i am checking all possibilities
 

·
Registered
Joined
·
41 Posts
Discussion Starter #12
Well i put a set of 75hp vco injectors from DAP in and they worked great! My miss went away and i got a little more power now
 

·
Registered
Joined
·
41 Posts
Discussion Starter #13
They only set me back 467$ but the core will take it back down to 367$
 
1 - 13 of 13 Posts
Top