Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of October's Cummins of the Month Challenge!
1 - 6 of 6 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
So I bought this truck all seemed well until I got at home the battery died the first night so I took the battery and got it tested and it turned out that it was bad. So I slapped a new battery in and thought all would be good. It was not! So I grabbed my voltmeter and checked the battery while the truck was running and found that the alternator was not charging probably due to the faulty external voltage regulator that was wired in so I pulled that out and converted it back to the stock wiring then changed out the faulty ECU for a brand new one Still nothing I changed out the CPS sensor along with the ASD relay all to no avail the ecu still will not ground out pin 87 on the ASD relay and still no tech in the cab I checked the wiring from the CPS all which is good and working the ECU is getting a signal from the CPS. I also deleted the fusible links. I’m completely stumped please help
 

·
Registered
1990 Dodge w250 12v Cummins (under construction). 2018 Ram 2500 6.4L
Joined
·
1,945 Posts
Check this video out



2018 2500 6.4L Hemi Tradesman
1990 5.9L 12v Cummins W250
 
  • Like
Reactions: Jdwnch

·
Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
Thanks for the video unfortunately I’ve done all this except jump the ASD I will do that it the morning all signs are pointing to a bad ecu but I can’t understand that because it’s brand new! Ugh
 

·
Super Moderator
Joined
·
23,343 Posts
Perfect reason why most will do a external regulator or a 1 wire alternator. So much simpler and trouble free.

Did you gap the CPS at .050?
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #5 ·
Yes I did and the ecu is getting a pulse between 5v and 0v

I just jumped the ASD relay and couldn’t notice a difference so I started the truck and removed the alt cable and tested it it was charging but only about .75v it didn’t hit 1.23v until about 2000rpm
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #6 ·
On another note when I jumped the ASD the ecu grounded the blue/yellow tracer wire it just won’t do it with the relay plugged it “The relay is known good”
 
1 - 6 of 6 Posts
Top