Dodge Cummins Diesel Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
new to the forum, hello everyone, heres the deal. i have had a 93 12v for about 1 year without a glitch, 232k on it, i was driving it yesterday all day and at the end of the night it shut down but restarted 2x's. went home, started fine in the am, went about 2 miles and shut again, started, went about, 100 yards and sounded like it was fuel starving, now it won't start at all. i am getting fuel to the lift pump and injector pump but not to the injectors, could it be injector pump? crank sensor?
 

·
Registered
Joined
·
3,578 Posts
Most likely, it's an intermittent short in the fuel shut off solenoid. It's a little spade connector on top of the injection pump with one wire going to it; that wire needs a constant voltage for the engine to run. Next time it won't start, with the ignition on, use a meter or test light to verify that the wire has voltage. I'll bet that it doesn't, and you just have to find the electrical gremlin.

If it's not an electrical gremlin, it's a air-in-fuel gremlin, and that's a gremlin species straight from the depths of Hell.
 

·
Registered
Joined
·
316 Posts
You could also try putting some compressed air to the tank while trying to start it.
 

·
Registered
Joined
·
1 Posts
I don't see that you reposted but I have this problem when I change my filter sometimes. I usually wiggle the harness that runs down to the solenoid. The solenoid does not activate when you initially turn the key to run, but when its turned to start and then continues to stay on for the duration. If you have a friend turn the key you can reach under the solenoid and check when it cranks if it pulls up. The only time mine does it is when I change the filter, I then wiggle the wires and forget about it until the next change. Best of luck.:beer
 
1 - 4 of 4 Posts
Top