Dodge Cummins Diesel Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
hello,
I recently have been having a problem with my 12 valve. Once it gets semi warmed up and i get into it a little bit it will miss,chug, diesel and die. I replaced the filter right away and put additive into the fuel checked for leaks and cant find anything i also moved the star wheel in the afc back so it was hitting the spring dont know if that had anything to do with it or not. I have not measured fuel pressure yet. but im leading toward a lift pump or the fuel bypass from reading some articals the weird thing is if i turn it off and restart it it seems to be fine

I had a similar problem this summer and replaced the lift pump and that cured it but when it would stutter i could press the prime ball and it would be fine this time around the prime ball is pretty hard and can barely pump it. Any help youd be great
 

·
Registered
Joined
·
17,617 Posts
...... if i turn it off and restart it it seems to be fine

I had a similar problem this summer and replaced the lift pump and that cured it .....
Lift pumps either work or they don't. They also last about 300k miles, I have only replaced mine twice. Don't spend your money on another one, you have other problems. Have you replaced the overflow valve, the rubber fuel lines and checked the tank module for corroded fittings? Pumping it up indicates an air leak problem, so that is where I would go first. The only OFV failure I have had caused hard starting, with lots of smoke and missing, but after less than a minute the engine ran fine and wouldn't hard start again unless it had sat overnight.
 
  • Like
Reactions: 34kmotorsports

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Okay so i got to measuring fuel pressure today thanks to the forum i drilled and tapped the banjo bolt and installed a needle valve and then hooked up the gauge at idle i have about 26psi and at 2500 rpm with no load i have 35-36psi so the pressures are right in the ball park went to drive it with the gauge on and when it started to act up found the pressures were still good but found out there was a fairly strong clicking coming from the front of the ip pump and at the overflow valve also when you shut it off it makes a loud pop. So im leaning towards the overflow valve sticking

I was wondering if anyone else has experianced this as well? also something odd there are times when i can have the throttle all the way down and it will do nothing at all then other times i can completely let of the throttle and have the rpm increase.

Help and ideas are greatly appreciated as this is my first diesel truck and really love except cant really drive it the way it is lol
 

·
Premium Member
Joined
·
16,224 Posts
Sounds like severely slipped timing to me.
 

·
Premium Member
Joined
·
16,224 Posts
any updates on this?
Unfortunately a large number of people never come back to report after their problem is fixed.
You're much better off to start a new thread with your problem rather than bringing up old ones.
It costs the same:)
 

·
Registered
Joined
·
8 Posts
i am having the same rpm increase when letting off throttle and rough idle, no power. waiting for my gauges to come in. very interested in your fix if you've found one
 
1 - 8 of 8 Posts
Top