Dodge Cummins Diesel Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
The transmission is a fresh rebuild was working fine. The trans was in fourth gear and just started down shifting all the way to second for no reason. Anyone know why this would happen? The trans would shift up when off the throttle but then down shift once again. Any help would be appreciated.
 

·
Registered
Joined
·
7,185 Posts
Sound's like your TPS is going out .Or out of adjustment . Did it feel like it was dropping out of Over Drive or going down into 1st gear ?
 

·
Steak N' Eggs
Joined
·
398 Posts
chk trouble codes?

The transmission is a fresh rebuild was working fine. The trans was in fourth gear and just started down shifting all the way to second for no reason. Anyone know why this would happen? The trans would shift up when off the throttle but then down shift once again. Any help would be appreciated.
Hi, I agree with SIMPLYSMN, symptoms seem like TPS stuff. Hope it IS just an adjustment. Have you checked the trouble codes though? Might confirm a short there. Also since it's a fresh rebuild you might double check the plug connections down there where the last work was done to be sure they're dry and clean and connected properly.
Get codes by turning ign on/off, on/off, on & leave on then count the check engine light blinks. codes will be 2 digits separated by slight pause. You can re-do the ign thing if you don't count right the 1st time. Here's the code key.
'92 and '93 Trouble codes - Dodge Diesel - Diesel Truck Resource Forums
Good Luck, TK
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
Yes it felt like it dropped overdrive and went to first. I believe that I have a code 12 and a code 24 . If I remove the tps from my injection pump but leave the wires connected should the transmission shift all gears except over drive without hurting anything? Oh thanks for the info.
 

·
Registered
Joined
·
7,185 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
trans down shifting

My trans is still down shifting . I put a tps delete kit in the truck for the first 15 miles the trans worked perfect the it started downshifting again it doesn't want to pull in low without high rpm. basically once the transmission is warm it acts up. the trans is a new rebuild and was working fine for the first 500 miles . does anyone have an idea what my problem is?
 

·
Registered
Joined
·
7,185 Posts
You have something Wrong with your Trans then . I would Take it back to who ever Built it .
 
1 - 8 of 8 Posts
Top