Cummins Diesel Forum banner

06 tach problems

344 Views 3 Replies 2 Participants Last post by  Noah Blauert
So I have a ranch that does not work… no buggy since I have a cts edge that will read my rpm’s but would be nice if all my gauges worked.. anyways I did the whole “leave the screws around the tach out” and I re solder ( did this 2x because nothing changed the first time so it was piece of mind for a l other go round) the pins on the Instrument cluster computer that are correlated with the tach. Put it all back together and when I turned the key I saw the tach jump up and when I went to start the truck it stayed at 0. Is there anything else that would cause the tach to not work?
1 - 3 of 4 Posts
I tried repairing mine several times like you. Sometimes, no change. Sometimes worked for 5 minutes, then back to erratic. I ended up sending it out to a repair service (on eBay). cost $130 or so. There are cheaper and more expensive out there. there are also faster ones and slower ones. This was important to me because when I removed the gauge cluster, the truck was undriveable. When I got it back, the gauges worked. So if you can't get anything out of it, maybe try sending it out. They did claim that they may not be able to fix clusters that someone else already "tried to fix". Well that was my case, and yours too. But it works now, so they did fix it.
Thank you for the info, it doesn’t bother me to much honestly. But I wouldn’t mind if it worked hahah just didn’t know if maybe there was a tach sensor somewhere that may have gone bad, considering when I put it back in after my “try of a fix” the needle jumps but doesn’t read 🤷🏼‍♂️
Anybody know if maybe the motor for the tach is out? I’m not sure if that’s a thing but maybe there’s more test to do to narrow down what is actually wrong
1 - 3 of 4 Posts