Dodge Cummins Diesel Forum banner
21 - 26 of 26 Posts

·
......................... .....
Joined
·
2,727 Posts
i always start the bolts for the injectors, leave loose, very loose. tighten lines, so the connector tube twists the injector and seals. then torque the injector hold downs
 

·
Registered
Joined
·
32 Posts
Discussion Starter · #22 ·
Got it!!

:thumbsup:hyper: alright!!!! I finally got a chance to work on the truck again. I was getting ready to do another injector swap last night, thinking maybe I just got bad ones. And when I went to remove the number 1 supply tube, i noticed that it was not seated good. I re togeteorqued it, put it all back together, did some serious praying! Aalnd it fired right up.
Bad news is it has no power at all, apparently what ever was causing it to lose power with a load, has got worse.
maybe lift pump?
Thanks again for all yalls help,
Brent
 

·
Mr. Vehicle Destroyer
Joined
·
11,787 Posts
lift pump possibly, have you changed the fuel filter lately?
 

·
avatar challenged
2021 DRW CCLB 4X4
Joined
·
4,622 Posts
just watching this one because i am having the same no start problems, i have a leaking rail valve tho, i also have unplugged my FCA and it doesnt start either
 

·
Registered
Joined
·
10 Posts
05. Does the injector wiring go through the valve cover, or is it like the ‘06 and is part of the valve cover gasket. My son has an 06 and lost power. Turned out it was dirty contacts on the connectors that go to the valve cover, we cleaned and burnished the contacts and all is well. The front connector feeds 1, 3, & 5, the back connector 2,4,6.
 

·
Vendor
Joined
·
15,049 Posts
Being an almost 14-year-old thread, makes me think they fixed it.

That info may help someone currently.
 
21 - 26 of 26 Posts
Top