Dodge Cummins Diesel Forum banner
1 - 4 of 4 Posts

· Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
i looked my best to make sure this hant been asked- some similar but not exact. i put LED headlites in bout 2 years ago and just lately felt lites were dim. quick check revealed drivers low beam and passenger high beam not working- has no power. iv done some tracing and checking with a simple test probe but find no answer. underhood wiring is virgin and no obvious burnt wires. checked fuses in innerfender box. nothing was added or changed during this time. cant understand why one headlite 6 foot away from the other could loose power. please help...
 

· Admin/Mod
I Still Know Nothing
Joined
·
4,061 Posts
Some of those fuse boxes are known to get corrosion or blow a trace.

I haven’t really seen many FCMs go, but they are cheap on eBay or at the junk yard.

Also note: If you drop in a 1500 FCM, you get rid of the out of park alarm horn…
 
  • Like
Reactions: Jaysz28

· Registered
Joined
·
15 Posts
I have an 04 dodge ram that I bought off the show room floor and a year after purchase I kept getting lamp out on the dash and kept replacing bulbs just after a day or so lamp out. I pulled the rear tail tight out and there is a metal strip that the bulbs attach to and when I tested the strip it was bad. I showed the dealer and mechanic what I found and asked them to prove me wrong and sure they replace both lamps and no more lamp out. I have replaced all head and tail lights with LED set up. My suggestion is test them before installation with an OHM meter.
 
1 - 4 of 4 Posts
Top