Dodge Cummins Diesel Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
225 Posts
Discussion Starter #1
Alright,
A friend of mine just called me and asked me to see if anyone knew what was going on.
He took his truck (which was running fine) to a dealership for some suspension /steering work and to have his valves adjusted. This truck is way out of warranty so he didn't put it back to stock. He's got the BD something or other crazy larry?!? I'm a 12 valve guy, I'm not sure what all its got.
Anyway.....
He got it back drove it about 1 mile from the parking lot and all was well, then out of nowhere it started running like crap and his downloader read these codes:
-P0073- Ambient sensor low ???
-P0882- TCM (maybe PCM) power low (I couldn't hear him that well
-P0107- Map sensor
and his airbag light and malfunction indicator light came on.
We know they disconnected the batteries to replace the power steerin pump, but otherwise I don't know what they touched.
Any ideas????? Sorry so long.
Thanks,
-R.J.
 

·
Registered
Joined
·
225 Posts
Discussion Starter #2
Nothing? My thought was a bad MAP sensor.
That would explain the engine de-rating itself, the MAP sensor code, ambient temp code.
Dunno about the TCM code.
Does this sound right to anyone?
Thanks,
-R.J.
 

·
Registered
Joined
·
521 Posts
maybe

just an outside the box opinion because I have a very limited knowledge of vehicle electronics...but... maybe they didn't tigten the battery cable down enough and a mile later it shook loose or atleast a bad connection, or maybe the old battery cables were worn and cracked and the mechanic caused the cable to finally fail???
 
1 - 3 of 3 Posts
Top