Dodge Cummins Diesel Forum banner
  • Hey everyone! Enter your ride HERE to be a part of October's Cummins of the Month Challenge!
1 - 14 of 14 Posts

·
Registered
Joined
·
272 Posts
Discussion Starter · #1 ·
hey guys got a quick question, my cousin has an 03 cummins and thinks his lift pump could be goin out. would he have hard starts if it was on its way out? and also would he have the same lp setup as my 06? TIA!
 

·
Premium Member
Joined
·
25,250 Posts
If he has the oem pump, it will be located on the back of the fuel filter housing, you have the intank model.
In most cases, if the filter mounted pump fails, you are done.
There are several things that can lead to hard starts, start with the fuel filter, look at the air filter while your at it.



Dodge | Commins | Forum
 

·
Registered
Joined
·
272 Posts
Discussion Starter · #3 ·
the fuel filter was just changed and ill inform him to check the air filter. we dont thinks its injectors as there is no fuel in the oil. the only thing we could think of is the lift pump. i think he does have the oem pump. is there anything else that it could be?
 

·
Premium Member
Joined
·
25,250 Posts
IIRC, I believe there is a wire behind the A/C Compressor that should be check for damage. Edit, Sorry, that's for a rough idle.


The FCA can also be an issue.



Dodge | Commins | Forum
 

·
Driving around on Stilts
Joined
·
1,564 Posts
IIRC, I believe there is a wire behind the A/C Compressor that should be check for damage. Edit, Sorry, that's for a rough idle.


The FCA can also be an issue.
For once I agree with Mr. BBSpam, also it could be injectors as they don't have to put fuel into the oil but can just bypass it back into the return line, would need to do a leakback/flow test. Couple other things could be rail fuel pressure sending unit, or the rail pressure pop valve.
Are you getting a CEL??
Good Luck:thumbsup:
 

·
Registered
Joined
·
272 Posts
Discussion Starter · #6 ·
rp sending unit or the pop valve would make it start hard?
 

·
Driving around on Stilts
Joined
·
1,564 Posts
rp sending unit or the pop valve would make it start hard?
On mine the RP sending unit was going and it took forever to get it started, got lucky and had another truck to pull one out of to try......immediate difference.
If the pop valve has gone south it can/will bleed off rail pressure up to the point of hard/no start. Pull the banjo bolt and see if you have fuel....if you do the pop valve is toast, DO NOT order from the dealer, it will be almost twice the money that you can get one direct from Cummins.
 

·
Registered
Joined
·
272 Posts
Discussion Starter · #8 ·
are the pop valves the same as an 06? if so id just give him mine.
 

·
Registered
Joined
·
476 Posts
they have some rail caps on here for cheap. I'm not sure if you want to go that route though.
 

·
Registered
Joined
·
272 Posts
Discussion Starter · #10 ·
bump to the top
 

·
GA CUMMINS CREW PREZ & Captain of the USS FAILBOAT
Joined
·
5,245 Posts
what other symptoms is he having, like stated, a fried fca, bad lift pump, is it harder to start warm or cold? rail pressure sensor, relief valve, or even bad injector/s....
 

·
Registered
Joined
·
540 Posts
Does the thing have a hard time turning over? Does he have OEM batteries, I just had to replace both of mine last month because they were both past the point of no return.
 

·
Registered
Joined
·
272 Posts
Discussion Starter · #13 ·
what other symptoms is he having, like stated, a fried fca, bad lift pump, is it harder to start warm or cold? rail pressure sensor, relief valve, or even bad injector/s....
well the truck can be warm and still not wanna start. we had it out last sat. was driving for prob. 45 min so the truck was plenty warm shut it off and it didnt want to start back up, it just cranks and cranks and then it finally catches and fires up.
 

·
Registered
Joined
·
272 Posts
Discussion Starter · #14 ·
Does the thing have a hard time turning over? Does he have OEM batteries, I just had to replace both of mine last month because they were both past the point of no return.
no its doesnt turn over sluggish like its the batteries. it spins over just fine, it just doesnt want to fire.
 
1 - 14 of 14 Posts
Top