Dodge Cummins Diesel Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
Hello, I have an 03 Cummins with no major mods aside from a Smarty S06 tuner. The truck runs awesome all through the power band and has no issue when it is running. However when I come to a stop at a stoplight, and then accelerate after its been sitting at the light my Rail pressure drops from 5500-6000K to Nearly 3000K for what appears to be a split second. It feels almost as a hiccup or a delay in acceleration. Once the truck is up to driving speed, there are no issues at all.

Also if the truck idles for more than a couple minutes there is a slight misfire and the truck revs up to like around 1000 RPM for a second or two and then drops back to normal.

All these issues seem to have started after summer arrived here in Vegas, and I began using my AC. It seems as if I turn off my AC all these issues go away.

Any input would be greatly appreciated.
 

·
Registered
Joined
·
760 Posts
Not sure if this is your issue but , I have seen the wire going to the ac compressor clutch right under the oil filter rub through the insulation and cause intermittent idling problems . Might be worth checking out ..


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
24 Posts
Discussion Starter #3
Not sure if this is your issue but , I have seen the wire going to the ac compressor clutch right under the oil filter rub through the insulation and cause intermittent idling problems . Might be worth checking out ..


Sent from my iPhone using Tapatalk
Ill definitely give it a look as the issue seems to be definitely tied to AC during idle. My next suspect would the FCA...considering my rail pressure acts weird during all these issues.
 
1 - 3 of 3 Posts
Top