Dodge Cummins Diesel Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1
My 03 has 170,000 miles on it and recently has got harder to start and some mornings takes 5 or 6 cranki9ng cycles.I have even taken the fuel filter out and put it back in and sometimes it will start right up after that.I installed a new Raptor fuel pump 3 months ago and is still working fine.It lately takes 3-5 seconds before it fires up and then runs fine the rest of the day,but it doesn't like the mornings(exspecially if it is cooled off)everything I have found on here leads to injectors but i am wondering if there is any other things to check.Batteries seem a little week after a couple cycles and i assume they are stock since it was 6 months old when i got it and I haven't changed them.
 

·
TECH SPECIALIST
Joined
·
408 Posts
odds are you have an injector issue if you want i can email you the info on how to test the return flow
 

·
Registered
Joined
·
361 Posts
So it doesnt like to start when its cold? As in cold outside temps? Is it blowing white smoke? Could be injectors.....what about the grid heater?
 

·
TECH SPECIALIST
Joined
·
408 Posts
heater grid failures will set a check engine light. But to check them take a test light and see if you have power coming to the grid.
 

·
Registered
Joined
·
31 Posts
Discussion Starter #7
No white smoke and what I mean is not ran for 8-10 hours.
 

·
Registered
Joined
·
31 Posts
Discussion Starter #8
MDCODY101 would you send me the steps to test the injectors please?
 

·
Registered
Joined
·
31 Posts
Discussion Starter #9
Went to tow it home yesterday and it fired right up and ran perfect.What gives,I don't want to drive it if it is going to screw something up.
 

·
Registered
Joined
·
31 Posts
Discussion Starter #10
I have noticed when i go to start it if the wait to start light cycles fast it will start if it cycles slow it will not.I thought i read something about a grid heater or something going bad and will cause a no start,can anyone help me with this?
 

·
Registered
Joined
·
260 Posts
I have heard that people are taking em out. Sounds like a grid heater issue not injector issue due to the fact of abnormal cycling.
 
1 - 12 of 12 Posts
Top