Gauge cluster intermittent on/ off - Dodge Cummins Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 03-07-2018, 02:13 PM Thread Starter
Newbie
 
Join Date: May 2015
Location: Central Oregon
Posts: 18
Thanks: 1
Thanked 1 Time in 1 Post
iTrader Score: 0 reviews
Gauge cluster intermittent on/ off

2004 Ram 2500 Cummins. Speedo, oil pressure, and temp will not work intermittently. Have done the cluster reset and all gauges make the sweep. These gauges will go off and on sometimes with the release of the parking brake. May be the jolt on the dash. They will come on when I press and hold the trip set button and quit again when released any help or direction is appreciated .
Thanks

74vette is offline  
Sponsored Links
Advertisement
 
Closed Thread

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Dodge Cummins Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome