Dodge Cummins Diesel Forum - Reply to Topic
2013-2018 General Discussion General Chit Chat About the 2013 model year differences 6.7L 4th generation Cummins - NO ADVERTISING -

Thread: I give up / Morimoto LED Fog Light Kit Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Dodge Cummins Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
02-15-2020 10:17 PM
Opie011 Dang it...lol

Guess I'll keep researching!
02-15-2020 09:53 PM
Jimmy N. Uh, oh. That's exactly what I'm running, too.

Had I installed the XBs with OE bulbs in the headlights I may have been somewhat impressed, but...
02-15-2020 09:48 PM
Opie011
Quote:
Originally Posted by Jimmy N. View Post
I'll have to look up what I ended up paying for them, Opie.
Anyway, they have maybe 5 minutes of usage on them.

What I didn't like was the light output when used in conjunction with good LEDs in the quads.

Oops, and I just realized that I had the ones for the 1500 in mind. They won't fit your 2500.
Once I have the 3500's headlight situation figured out, I can let go of the XBs for that one.
No worries.
I have the HR V4s for my lows in my quad lamps and hoping these XB wont disappoint.
02-15-2020 09:32 PM
Jimmy N. I'll have to look up what I ended up paying for them, Opie.
Anyway, they have maybe 5 minutes of usage on them.

What I didn't like was the light output when used in conjunction with good LEDs in the quads.

Oops, and I just realized that I had the ones for the 1500 in mind. They won't fit your 2500.
Once I have the 3500's headlight situation figured out, I can let go of the XBs for that one.
02-15-2020 08:43 PM
Opie011
Quote:
Originally Posted by Jimmy N. View Post
I could sell you a very lightly used set. I'm looking for something better.
PM me a price if you dont mind.

What do you not like about them?
02-15-2020 08:21 PM
Jimmy N.
Quote:
Originally Posted by Opie011 View Post
I think I'm going to have to order these morimoto xb fogs as one of my LED bulbs finally went dead. Hopefully they're going to have a sale soon 🤞
I could sell you a very lightly used set. I'm looking for something better.
02-15-2020 08:14 PM
Dogpatch
Quote:
Originally Posted by Opie011 View Post
I think I'm going to have to order these morimoto xb fogs as one of my LED bulbs finally went dead. Hopefully they're going to have a sale soon 🤞
I like mine.
02-15-2020 07:58 PM
Opie011 I think I'm going to have to order these morimoto xb fogs as one of my LED bulbs finally went dead. Hopefully they're going to have a sale soon 🤞
02-01-2020 12:06 PM
Dogpatch
Quote:
Originally Posted by Loki223 View Post
Just to make sure, you are referring to these?

Dodge Ram: XB LED - Fog Lights from Morimoto HID

The LED Projector fog lights? Or are you referring to an LED Bulb inside of a fog light housing?

I ran the X8 Projector fog lights on my 12 for several years, no resistors, no issues.

When i upgraded to my 18, i continued the plug and play approach, Just plugged them in. No issues, no resistors, no canbus cancelers, nothing. When i adjust settings for HID headlights the only fog light setting i changed was to disable the fog light drop out. I have had zero issues with the X8 Projector LED fogs

My Suggestion, with them haven worked for several years, is to check your grounds and your connectors. Sometimes the connectors might get loose, which can cause intermittent issues. Make sure your pins are fully seated and making proper contact. Especially since when you bench test the lights they work

The way the canbus system works, is at startup it will check the lights for any lights out. If it detects any issues, it will turn off power to that light, so the reason your factory light might not have worked at first is because it detected an issue, turned off power, then after a power cycle it checked again, and did not find an issue so it kept power on. I would lean towards the issue being more with the Morimoto light, or with the connector. Also, the morimoto staff is very knowledgeable and helpful. giving them a call might throw out an idea on something to check that none of us might think of that could solve the issue. If anyone else has ran into your issue, the manufacturer would be a fantastic place to start for assistance in troubleshooting.
Like you, on my 2015, the finickiest MF’ing truck on the planet when it comes to lighting, I just swapped the OEM fogs with the Morimoto XB LEDs. Didn’t have to OBD nothing in the computer. Plug and play with original harnesses. Couldn’t believe it was that simple. No issues for over a year now.
Here’s a couple of pics of the even low Broadcast pattern, light set up and Fog lights only pattern on the road.
Note, I’ve since changed out my HID bulbs to 5500k so they are whiter than in the photo.
02-01-2020 11:58 AM
CumminTryMe That yellow light would annoy the piss out of me.
02-01-2020 11:08 AM
Jimmy N.
Quote:
Originally Posted by Suny View Post
as we all love pics - here some references

1 Yellow OEM Fogs only ( Alla Lighting H10 LED Fog Lighghts 3000K Amber Yellow)
Mike, looking at those photos it's painfully obvious that your fog lights don't work as fog lights.
They put light higher than the low beams do, despite being mounted much lower.

It's not just an adjustment issue, unfortunately, as the OE fog lights have such a bad beam pattern that they really can't be adjusted correctly. They're best used as DRL, I think.
02-01-2020 07:09 AM
Suny and yes, here the christmas tree
This thread has more than 12 replies. Click here to review the whole thread.

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome