Dodge Cummins Diesel Forum - Reply to Topic
4th Gen Powertrain Discussion of components that are directly involved in the power production and all that is needed to get and keep the truck moving . Engine, Transmission, etc...NO ADVERTISING

Thread: Truck smokes ALOT on start up, other problems Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Dodge Cummins Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
07-29-2019 02:06 AM
frankss If its more of a white smoke that would be an over fueling issue.... maybe a bad injector. You have a IR Thermometer?
07-28-2019 05:53 PM
Timmyh No, I meant the 3500 rpm bit. Foot to the floor, 5th gear at 2200 the boost gauge finally starts coming off 0. Around 3500 it hit 12. I let off shortly after.

As far as the clutch slipping and de-rating, I never noticed it before swapping turbos. Just let off as soon as it started to slip. I have not changed the tune yet and I just got done running a short data log. I have a south bend sitting on the shelf waiting to go in. Just trying to figure out why it will hardly idle and smoke like crazy first

Yes, leak test has been done. Not seeing any
07-28-2019 03:34 PM
the man in black Was "12 pounds of boost at 3500rpm" a mis type or did you mean to write 3500 rpm.
07-28-2019 02:12 PM
N of 60 Engine will derate with a slipping clutch. New turbo and connections have obviously been leak tested? It does not sound like you changed your tuning since you changed your charger? You have data logged these events to show your tuner?
07-28-2019 01:18 PM
Timmyh Clutch is sitting in the garage, ready to go in. Trying to figure out why the truck barely runs before I spend time with that
07-28-2019 01:11 PM
N of 60 Factory clutch and performance tuning? Start with matching those two and go from there.
07-28-2019 12:49 PM
Timmyh Truck is right at 100,000 miles. Only mods are the deletes with ez lynk for tuning (korey Willis tunes) and now this S363 from High Tech turbo
07-28-2019 11:22 AM
frankss Whats the milage, mods, any other info to help diagnose problems?
07-27-2019 02:48 PM
Timmyh Hey all, I'm at my witts end with my 4th gen. Problems started around a month ago. First, I would consume a tank of def in 200 miles. Dealer wanted 2200 dollars just to look at it. Decided to solve that problem and a few others permanently instead with ez lynk. Truck ran great on a 700 mile trip, towing a trailer across the Rockies. Only thing wrong was my exhaust brake was acting up and not working much. Next morning it was hard to start but ran fine otherwise. My wife took the truck to town that night and I noticed a blueish smoke coming from the exhaust when she got home. I noticed later that both my oil and coolant levels were dropping. These led me to believe the turbo was failing. Jump forward to last night, I get the s363 drop in from HTT. After install, I fired it up and the smoke from the exhaust is worse, truck idles HORRIBLE and I can only make 12 pounds of boost at around 3500 rpm. With the ez lynk and stock turbo, the clutch would slip on stage 2 and above. Last night, I cranked it to stage 5 and floored it and the clutch held. Truck has absolutely no power.

Any help at all would be great. Or if someone wants a 2015 6 speed manual 3500, come get it

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome