Dodge Cummins Diesel Forum - Reply to Topic
2010-2012 General Discussion General Chit Chat About the 6.7L 4th generation Cummins - NO ADVERTISING

Thread: Delete Coolant Leak Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Dodge Cummins Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
05-02-2019 10:49 AM
DMan1198
Quote:
Originally Posted by kens_isb View Post
and how would you do that?
This is my setup. Itís a modified stock pipe from source automotive.
05-02-2019 10:47 AM
DMan1198 Insufficient lubrication on install is often the cause of o-ring failure when it looks like that. I generally use petroleum jelly on any o-ring I install.
05-01-2019 08:23 PM
drwaggs Not sure how it happened, but bad O-ring right after or during install. Easily fixed with new ring.
04-21-2019 10:04 PM
kens_isb
Quote:
Originally Posted by DMan1198 View Post
What N of 60 said.
and how would you do that?
04-21-2019 09:01 AM
DMan1198 What N of 60 said.
04-20-2019 09:34 PM
N of 60 Or remove the bypass all together, no more anything to leak.
04-20-2019 07:02 PM
98whitelightnin I replaced the oring on mine too and my leak quit. Find the biggest oring that will fit and get a handful of them
04-20-2019 06:02 PM
Cajunberry I had the same issue after doing my delete and found the issue to be a bad o-ring. I’d pull the connection out and look at that first. Found a new o-ring in a o-ring kit from harbor freight tool. Hope this helps
04-20-2019 04:39 PM
drwaggs
Delete Coolant Leak

Finally deleted, but I have a leak. See pic. I've read other threads that lead to a Glacier Diesel Heater Hose adapter. Will that work here or are there better fits?

Thanks

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome