Dodge Cummins Diesel Forum - Reply to Topic
3rd Gen. Powertrain Discussion of components that are directly involved in the power production and all that is needed to get and keep the truck moving . Engine , Transmission Ect...NO ADVERTISING

Thread: Re-post (Injector problems) Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Dodge Cummins Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
04-18-2019 01:48 PM
Mr.Jones Ssteve I would like to know also?
I plan to dig into this and get my $ back from Dodge if they didnt follow the proper dodge / cummins procedures.
Steelhead1 I don't hand calculate every tank I know my overhead is off. I don't want to hand calculate when I'm driving from diesel pump to pump.
All information is valid.
I will update the on the truck tomorrow.
Thanks for your time.
04-18-2019 01:38 PM
Mr.Jones Brought the truck to an actual diesel shop today.
Lift pump is only putting out 5 (psi or #s?) drops to 3 when warmed up.
Ran the injectors, computer cutout test, balance test....
They don't know why Dodge would look at there scanner see the fuel pressure drop to 0 in 4 seconds, then do a manual cut out test.
The truck runs fine just bad mpgs, and it seams like some loss of power.
The shop owner and three techs looked at the write up from dodge and told me they where trying to rip me off.
-I dont know what standard procedure is at Dodge?
New Fass pump going in tomorrow morning.
I appreciate everyone input.
04-18-2019 03:55 AM
steelhead1 Any "rebuilt" injectors often have excessive wear/pressure cutting damage to the connector tube>injector dimple sealing surface. Leaks here go back to fuel tank, causes screwed up computer idiot gauge mileage readings. So will the return valves in "rebuild" injectors, the bodies are often distorted from millions of opening pressure cycles, don't hold valve correctly any longer.
Above stock OEM new fuel return amounts drive these Dodge Mopar computers crazy. That overhead is brighter than some Ram Diesel owners though.

ONLY post real MPG calculations, most adults with a brain are capable of doing this.

If that dealer shop did not run a balance test, they don't have the right to call themselves a diesel shop. Common that socalled "rebuilts" have major flow balance issues across all 6, often 10%++ which really screws with the dumb brain on these always trying to catch up balancing the power output across all 6. Overfuels some, underfuels others. Kicks the total power out HP torque in the balls. Easily lose 100 hp pulling from unbalanced cylinder load output.

Last thing one wants in one of these is the Mopar Mexican Taco Truck rebuilt injectors from Saltillo. Quality control is even worse than the trucks.

Pull the injectors. Run a compression and leakdown test for any piston/ring/cylinder/valve damage.
Put in NEW BOSCH or BBI's with new tubes. those tubes you bought are most likely damaged by those old reused bodies.
04-17-2019 11:35 PM
ssteve I need to know what test the dealer was doing when the rail pressure drops off in 4 seconds.
04-17-2019 11:22 PM
mellowme
Quote:
Originally Posted by Mr.Jones View Post
Ssteve thanks for the input but...
I don't feal like you read my long winded bit...
My bet is he did read it! Remans are considered junk by almost everyone in the know. Compression test is a valid test under the circumstances. As is contribution. Your falling rail pressure is not a positive sign, but could be leaking pressure relief unless you capped all 6 injector feed tube lines to get your one good hold. I would not put remans in my common rail. It costs to much to repair the damage they can do. Which your hung open injector may well have done as it does not take long.
04-17-2019 11:14 PM
ssteve What I read is that your fuel mileage sucks after you installed injectors and you wanted input. Is that correct?????
04-17-2019 10:44 PM
Mr.Jones Ssteve thanks for the input but...
I don't feal like you read my long winded bit...
04-17-2019 09:34 PM
ssteve First thing I would do is pull the injectors and and do a compression test. You did say that a injector stuck open, maybe it did some damage to the cylinder. If that checks out have a shop do a cylinder contribution test to see which injector isn't spraying right. Then replace all injectors with new!
04-17-2019 09:24 PM
Mr.Jones Fealing long winded today
No the injector knock and white smoke was taken care of by the injectors.
Starts up in a couple of cranks 1-3 seconds cold.
I bought the injectors from this place because a friend that's a heavy equipment mechanic installed them in his 03 5.9 and never had a problem.
There Bosch certified for what it's worth.
I can't wrap my brain around how I tow a 16ft cargo trailer everyday with at least 1.5 tons in it and all the injectors are bad???
Maybe 1 or 2 but all bad & back feeding?
Not hand calculated, not worth it, the dummy reader says 11.7 With just the trailer.
Put the slide in camper on it & trailer 10 - 10.5.
Driving from gas station to gas station.
04-17-2019 09:08 PM
booomer27 I would guess it is an issue with the reman injectors. Most people on here will tell you never to buy reman injectors unless they are from BBI as it seems most people have issues with remans. If you are only getting 8-9 unloaded hand calculated something is definitely wrong, any injector knock, white smoke, hard starts.
04-17-2019 09:03 PM
Mr.Jones Looking for any help here guys and gals....
All I can think of is to pull an injector and have it tested?
I also just read on another thread that the injectors should be loosened up to reseat a crossover tube?
So maybe a new set ofcrossover tubes, seated into in torqued injectors and re torqued might fix the back flow issue?
04-17-2019 08:31 PM
Mr.Jones
Re-post (Injector problems)

Hello everyone, this is my first post.
06 3500 stock 5.9 276k miles
So about a month ago heading to Dallas an injector decided to stick wide open (lots of white smoke at startup). With a slide in camper on the truck and a cargo trailer behind me I installed 6 Refurbished Bosh injectors from M&D diesel, crossover tubes, fuel filter, every gasket involved including the injector wiring harness & finished with a valve adjustment. All in a auto parts store parking lot. Took me all day.
-Problem 8-9 mpg & slight loss of power (before injector job 13-14mpg towing)
-So I pulled the crossover tubes, #4 had a half moon groove, replaced, retorqued , no change.
Wasted money on... map, Intake & Ambient air sensor, fuel high pressure release valve.
Brought to Dodge today to see what there fancy electronics would tell me.
-Fuel rail pressure drops off in 4 seconds
-Isolated injectors one at a time, rail pressure still drops. Isolate all injectors (single out fuel rail) holds pressure.
-Rail pressure is good
-Indicating faulty leaking
-Recommend replace all injectors & crossover tubes $4,200
Had them button it up & picked it up.
? Did I screw up my crossover tubes or injectors?
Truck still runs fine,towing every day. Just a slight loss of power, mpgs are doing me in.

Any input would be greatly appreciated, I'm going a bit crazy & debating on my next step?
The dealer's answer is not a possibility!
Thanks for your time...

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome