Dodge Cummins Diesel Forum - Reply to Topic
07.5 - 09 3rd Gen 6.7L Powertrain Discussion of components that are directly involved in the power production and all that is needed to get and keep the truck moving . Engine, Transmission, etc...NO ADVERTISING

Thread: Squeal around 30 PSI boost?? Reply to Thread
Title:
Message:
Trackback:
Send Trackbacks to (Separate multiple URLs with spaces) :
Post Icons
You may choose an icon for your message from the following list:
 

Register Now



In order to be able to post messages on the Dodge Cummins Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










  Additional Options
Miscellaneous Options

  Topic Review (Newest First)
04-14-2019 08:09 AM
El Pozzinator Yep. My 08 did it at ~12psi when I got a boot crooked and hadnít fully snugged a clamp. Sounds kinda like a flat horn reverberating under the hood by the turbo.

Check your clamps, boots, and anything plastic between the turbo and intake.

Good luck!


Sent from my iPhone using Tapatalk
04-13-2019 03:16 PM
Rhinopkc Boost leak. Had an 09 with a bad gasket at the intake horn to grid heater connection make a noise like that.
04-13-2019 01:45 PM
s10010001
Quote:
Originally Posted by GTIgus View Post
I have a video on youtube but the forum won't let me add it since I don't have enough posts... :-/


Just paste the link, we can click it just fine (or those of us that TapaTalk on mobile will see the video with just the link posted.


My 2000 had a squeal going around 38-42PSI, it was the horn boot, had a 1/2Ē crack forming coming from the clamp up.

It took forever to find it because it would not leak with my boost leak tester at 30psi, I didnít want to go higher. I found it visually when I pulled to horn off one day. Wasnít sure it was to source but when I replaced the boot it was gone.
04-13-2019 12:49 PM
GTIgus I have a video on youtube but the forum won't let me add it since I don't have enough posts... :-/
04-13-2019 12:47 PM
GTIgus Just visually, I haven't made a boost leak tester yet to pressurize the system. Do you think a split or hole would cause that symptom? Thanks!
04-13-2019 12:46 PM
gmbohuntr Did you check for splits in the boots?


Sent from my Pixel 2 using Tapatalk
04-13-2019 12:44 PM
GTIgus
Squeal around 30 PSI boost??

Hi All, I've got a 2008 CTD Ram 3500 with about 95k miles. I've only had the truck for a month or so.

When I got the truck I replaced all fluids and filters right away, then installed a full delete kit and 4" exhaust with muffler and H&S Mini Maxx.

About 2 weeks ago we took it for a 350 mile road trip drive to see some family. On the way home I pulled onto the interstate from a rest stop and got on it pretty hard. Around 30PSI of boost, as indicted by the mini maxi, I heard a squealing kind of sound coming form the turbo area, so I backed off.

Now, every time I get around 30 PSI boost Io get the same noise. There's no power or running issues otherwise, just the noise at high boost. I've checked for leaks around the manifold and turn mounting, as well as tightened all my intercooler boots to no help. Any ideas? Thanks in advance!

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome