EGT Probe replacement interval - Dodge Cummins Diesel Forum
ISSPRO

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 12-28-2017, 07:42 AM Thread Starter
Cummins Fanatic
 
Join Date: Aug 2009
Location: Alberta
Posts: 147
Thanks: 92
Thanked 15 Times in 15 Posts
iTrader Score: 0 reviews
EGT Probe replacement interval

Hi, I have the factory match EV2 pyrometer in my 07 5.9. I installed it in 2010 and it has about 80,000 kmís (50,000 miles) on it. The probe is installed pre turbo and I am wondering if Isspro has a recommended interval for replacement. I have had the reading on the gauge read 3 or 400 degrees high on two or three occasions in the last year, but once I shut it down and restart it, it reads back to normal. I donít know if that is a early warning sign of probe failure or just a a random anomaly in gauge function. I am also concerned of mechanical probe failure that it comes apart and damages the turbo. Please advise, thank you.


07 3500 QCLB, SRW, SLT, 4X4, 48re, Isspro EV2's:Trans in SRT10 pillar, EGT's, Boost, Rail and Fuel Press in O/H. GDP 2 mic and big line kit, GDP Airboss & Intake, Jake Brake, Dynatrac Freespin and Dynaloc's, Smarty Jr, Goerend 15SS converter, Superior S/K, PPE pan
Diesel On is offline  
Sponsored Links
Advertisement
 
Closed Thread

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Dodge Cummins Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome