Where to Start - Dodge Cummins Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 05-07-2019, 07:45 AM Thread Starter
Newbie
 
Join Date: May 2019
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Where to Start

Two things, while changing brakes on 2013 Ram 2500 outdoorsman, I noticed transmission fluid on passenger side of engine from top to bottom with oil on bottom of truck also from steering cylinder back along the truck frame. Where is the oil coming from? I cannot seem to find the source of the leak. Second, the truck is lagging when I shift into drive. I just bough the truck in January and it seems to be slowly getting worse. Where should I start with either of these situations?


Chris Hall
Chall is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 05-07-2019, 11:12 AM
On call 24/7
 
98whitelightnin's Avatar
 
Join Date: Oct 2008
Location: DFW
Posts: 12,136
Thanks: 1,900
Thanked 1,243 Times in 1,104 Posts
iTrader Score: 16 reviews
Sounds like the heat exchanger is leaking trans fluid, have you checked it or had to add any?

1998 12v, 4x4, Club Cab, Carli, Thuren, BlueTop, Core 4x4, BD Diesel, PDD 5x.012, South Bend
2012 Laramie Longhorn, EFI by Ryan, Carli, Thuren
1995 Dually, Weston's 5x.016, 4k GSK, 5" FloPro, 255/85r16 Toyo M/T, Goerend, ARP, 60# Springs, BW 62/65/14, BW 75/96/1.10, Isspro, Fass 125, BDP Sump, 7mm DV's, 751 HP 1883 FP Torque on NOS
1998 P-Pumped 24v, 4x4, NV4500 swap
98whitelightnin is online now  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Dodge Cummins Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2014 remote start disabled then no start TexasWalter 4th Gen Powertrain 2 11-30-2016 02:39 PM
2014 remote start disabled then no start TexasWalter 2010-2012 General Discussion 1 11-28-2016 08:22 PM
Only Start with starter fluid geosplash 07.5 - 09 3rd Gen 6.7L Powertrain 11 07-18-2016 04:48 PM
TRUCK WONT START - Please help inlinecumminspower 98.5-02 Powertrain 26 03-16-2012 02:12 PM
Wait to start light wire? eggineric 07.5 - 09 3rd Gen 6.7L Non-Powertrain 0 07-25-2011 01:24 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome