Only 32 PSI with 125s and compounds - Dodge Cummins Diesel Forum
98.5-02 Powertrain Discussion of components that are directly involved in the power production and all that is needed to get and keep the truck moving . Engine , Transmission Ect..NO ADVERTISING .

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 19 (permalink) Old 01-23-2020, 11:02 PM Thread Starter
Newbie
 
Join Date: Jan 2020
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Only 32 PSI with 125s and compounds

First post, any help is appreciated. My truck is a 2001 5 speed 240,000 miles. Has a Fass 150, BD injection pump, Edge Juice w/ Attitude, and stock over (i think) ~S300 compounds. I just installed 125 horse BD injector nozzles and have gotten almost no power gain over the nozzles i just took out, which I am 90% sure were stock. If I pin it from 1200 RPM in first gear itll blow a short cloud of smoke but then quickly cleans up around 15 PSI. PEAK boost is about 32. Ive read on other posts that people are making that if not more with 60 horse injectors. When I bought the truck it had the juice box under the hood but someone had removed the screen. I then bought a kit from Edge that included just the screen and noticed a small increase in power. Something is telling me the computer is not dumping fuel like it is supposed to even on the 5x5 tune. From a roll in any gear the exhaust is completely clean. So my question is why is the truck not pulling hard with 125s and compounds and peaks at 32 psi. Thank you all, I find myself on this forum almost every week, so figured I go ahead and ask the experts.

Gunner_24v is offline  
Sponsored Links
Advertisement
 
post #2 of 19 (permalink) Old 01-23-2020, 11:36 PM
Diesel Freak
 
Join Date: May 2014
Posts: 829
Thanks: 12
Thanked 43 Times in 41 Posts
iTrader Score: 0 reviews
Need more info on the atmosphere turbo. s400 frame turbos are generally used with the exception of maybe a s369.

-
99 Ram 3500 SLT 4x4, 19.5's, P24v, ZF6-750, s362/475, 7x0.014, supporting mods.
marco610 is offline  
post #3 of 19 (permalink) Old 01-23-2020, 11:51 PM Thread Starter
Newbie
 
Join Date: Jan 2020
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Its an S366 I believe. It was on the truck when i bought it as a single. Other than that dont know much about it. Didnt spool at all till around 2300 then would light up to 25PSI. Then I added an HX35 in a compound setup which spools fast and peaks around 30 PSI until I added these 125s, now I peak at ~32.
Gunner_24v is offline  
Sponsored Links
Advertisement
 
post #4 of 19 (permalink) Old 01-24-2020, 12:45 AM
Diesel Freak
 
Join Date: May 2014
Posts: 829
Thanks: 12
Thanked 43 Times in 41 Posts
iTrader Score: 0 reviews
Have you checked for boost leaks? I would be curious to see what you're getting for drive pressure as well.

-
99 Ram 3500 SLT 4x4, 19.5's, P24v, ZF6-750, s362/475, 7x0.014, supporting mods.
marco610 is offline  
post #5 of 19 (permalink) Old 01-24-2020, 01:47 AM
Diesel Freak
 
Killjoy's Avatar
 
Join Date: Feb 2016
Location: Southern Colorado
Posts: 762
Thanks: 2
Thanked 61 Times in 56 Posts
Garage
iTrader Score: 0 reviews
Also check map sensor.

2002 ram 2500 quad cab shortbed ST. Red, 4x4, nv4500 swap 24v, 66mm silver bullet, 100hp injectors , fass titanium 150, 4" exhaust, guages. 190k miles.
Killjoy is offline  
post #6 of 19 (permalink) Old 01-24-2020, 02:27 AM
Diesel Head
 
ofelas.5z's Avatar
 
Join Date: Feb 2015
Posts: 2,191
Thanks: 1
Thanked 243 Times in 218 Posts
iTrader Score: 2 reviews
Check the HX35 wastegate as well.

R12 in the summer, Webasto in the winter; cassette tapes & SAE-20078 all year.
ofelas.5z is offline  
post #7 of 19 (permalink) Old 01-24-2020, 11:48 AM Thread Starter
Newbie
 
Join Date: Jan 2020
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Quote:
Originally Posted by marco610 View Post
Have you checked for boost leaks? I would be curious to see what you're getting for drive pressure as well.
Ive checked for boost leaks and beleve im good. Dont know drive pressures becuse I dont have a guage for it yet, that and a fuel pressure guage are on the list.
Quote:
Originally Posted by Killjoy View Post
Also check map sensor.
MAP sensor seems okay, it is spot on with my mechanical boost guage, could that be the problem if say it was only reading up to that 32 PSI?
Quote:
Originally Posted by ofelas.5z View Post
Check the HX35 wastegate as well.
HX35 wastegate is pinned shut. How could this affect the low boost im seeing.

Reply for all. I cant help but think its an electrical issue. Maybe my programmer is not "compatible" with the box under the hood? Theyre both edge but i did do a roundabout way of making it work. When I called edge they said the box I had was discontinued so they couldnt help, so I went to another distributor that had JUST the screen, sold as an "upgrade kit" for people who had the small edge screen with the buttons and wanted the touch screen. But with all this being said all the gauges work on the screen and there is a difference between all the tunes.So I know its changing fuel an/or timing somehow. Could it be possible its changing ONLY the duration of the injection? and not actually pushing more volume for a given duration? <- If that makes no sense school me, I'm new. It just doesnt seem like its fueling the way it should. Gonna go out and run a check on all the connectors shortly. Thanks everyone for all the replies so far.
Gunner_24v is offline  
post #8 of 19 (permalink) Old 01-24-2020, 12:05 PM
Diesel Head
 
ofelas.5z's Avatar
 
Join Date: Feb 2015
Posts: 2,191
Thanks: 1
Thanked 243 Times in 218 Posts
iTrader Score: 2 reviews
The waste gate flapper may not be sealing well when closed.
Quote:
Originally Posted by Gunner_24v View Post
HX35 wastegate is pinned shut. How could this affect the low boost

R12 in the summer, Webasto in the winter; cassette tapes & SAE-20078 all year.
ofelas.5z is offline  
post #9 of 19 (permalink) Old 01-24-2020, 01:29 PM
Diesel Freak
 
Join Date: May 2014
Posts: 829
Thanks: 12
Thanked 43 Times in 41 Posts
iTrader Score: 0 reviews
You're going to want the waste gate functioning with compounds. Is the vp44 wire tapped? The edge situation sounds overly complicated. maybe you could sell that all for a decent price and get a Quad.

-
99 Ram 3500 SLT 4x4, 19.5's, P24v, ZF6-750, s362/475, 7x0.014, supporting mods.
marco610 is offline  
post #10 of 19 (permalink) Old 01-24-2020, 01:43 PM
Diesel Head
 
me78569's Avatar
 
Join Date: Jan 2012
Location: Colorado Springs Co
Posts: 13,214
Thanks: 789
Thanked 2,413 Times in 1,933 Posts
iTrader Score: 2 reviews
You need to stop throwing parts at it and test for boost leaks, verify the injectors are good and popping right ( who built your injectors? what did they set pop pressure to?), verify your wastegates are setup right.

Pump the breaks and figure out what you actually have and verify everything is good and working right. 125's are tiny injectors for that setup,

The quad is great, but it won't magically fix issues.

2018 3500 CCLB G56
me78569 is offline  
post #11 of 19 (permalink) Old 01-24-2020, 02:02 PM
Diesel Freak
 
Join Date: May 2014
Posts: 829
Thanks: 12
Thanked 43 Times in 41 Posts
iTrader Score: 0 reviews
Quote:
Originally Posted by me78569 View Post
You need to stop throwing parts at it and test for boost leaks, verify the injectors are good and popping right ( who built your injectors? what did they set pop pressure to?), verify your wastegates are setup right.

Pump the breaks and figure out what you actually have and verify everything is good and working right. 125's are tiny injectors for that setup,

The quad is great, but it won't magically fix issues.
Absolutely. One thing at a time.

-
99 Ram 3500 SLT 4x4, 19.5's, P24v, ZF6-750, s362/475, 7x0.014, supporting mods.
marco610 is offline  
post #12 of 19 (permalink) Old 01-24-2020, 05:12 PM
Diesel Head
 
Clunk's Avatar
 
Join Date: Apr 2008
Location: Tennessee
Posts: 7,652
Thanks: 1,182
Thanked 754 Times in 693 Posts
iTrader Score: 0 reviews
Quote:
Originally Posted by marco610 View Post
is the vp44 wire tapped? .
x2

'01.5 QC, SB, 6spd 4x4, Drag Comp, 4" exh. Jammer 100's, 62-65-.70A/R WG, adj.boost elbow Big Line, fuel press.pyro & boost gauges fuel cooler BHAF, Black Holley lift pump-12psi WOT Ceramic/Kevlar SD clutch, studs Take time to turn-so you don't burn
Clunk is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Dodge Cummins Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome