Got Smoke... Need Boost!!! - Dodge Cummins Diesel Forum
94-98 Powertrain Discussion of components that are directly involved in the power production and all that is needed to get and keep the truck moving . Engine , Transmission Ect...NO ADVERTISING

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 08-15-2006, 07:26 PM Thread Starter
Cummins Enthusiast
 
Ridemywideglide's Avatar
 
Join Date: Apr 2006
Location: CO.
Posts: 254
Thanks: 0
Thanked 1 Time in 1 Post
iTrader Score: 0 reviews
Got Smoke... Need Boost!!!

Got the hx40 on this weekend, took off monday so the pipe shop could stub out the pipe to under the bed.
Now it's a laggy dog compared to the hy35 that I took off of it..
Running no plate (came that way) and I had slid the housing all the way forward, and the starwheel is prettywell forward as well... I've never messed with the smoke screw, don't know about it's past history tho.
Been scouring the threads and see everyone asking for more smoke.. I don't want more smoke I want more power out of what it's wasting already.
Highest I've seen from this 40 so far is 35psi, my hy35 would almost push that and it came on alot quicker. I'm thinking I might swap back to the 35 and have my downpipe adapted to the new 4" pipe until I can get it lined out with what I need to do.
I also put in some injectors, but I'm unsure of what they are, closest I can pin down in marine application CPL1975 or 2205 so I don't know if they are 330 or 370 or what for sure.. But the only thing I noticed from them is my idle dropped about 200rpm and now the truck is back to the long-crank start until I get it adjusted.
Also, looking for a place to buy the required Y pipe and mandrel bends in 4 and 5 inch for stacks. No shop locally keeps anything that big.

Thanks
Brad


1996 2500 CTD, Ext Cab SLT, Longbed 4x4, 5 spd, 3:55's, 285/75/16's, Marine Cam, HX35, 5x012's, Hacked AFC, 191's, Autolite EGT, Boost & Fuel Pressure guages. 418/967 on the dyno...
To view links or images in signatures your post count must be 3 or greater. You currently have 0 posts.
2005 Wideglide, 98ci, 37g's, 10:1, race heads.
Ridemywideglide is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 08-16-2006, 11:21 AM
Cummins Fan
 
kevin1x's Avatar
 
Join Date: Jun 2006
Posts: 67
Thanks: 1
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
smoke = fun
kevin1x is offline  
post #3 of 7 (permalink) Old 08-16-2006, 12:44 PM
Diesel Head
 
Join Date: Dec 2005
Posts: 3,032
Thanks: 0
Thanked 57 Times in 15 Posts
iTrader Score: 0 reviews
What you may want to do is put a plate in it. You just might have enough fuel to actually start to 'put the fire out'. I would recommend you find a stock plate (most guys give them away after they change them) and grind it to a #100. Then start to adjust the starwheel for the pre boost fueling and the amount of somke you want at first. You MAY even see a slight increase in fuel mileage!!
Tom

Contact me at:
To view links or images in signatures your post count must be 3 or greater. You currently have 0 posts.
Tom05 is offline  
Sponsored Links
Advertisement
 
post #4 of 7 (permalink) Old 08-16-2006, 03:47 PM
Cummins Fan
 
Join Date: Apr 2006
Location: riverside, california
Posts: 83
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Smile

I kinda just finished the same thing. I put on a new S300, ATS intake/Exhaust, and 4" Diamond eye exhaust all the way back. 1st thing I notice is loss of bottom end, spool up/boost is slower, temps go higher faster, but come way down after spoolup and freeway cruisin below 2000 rpm. I would like to get the bottom end back so I can break my tires loose again, but over all i really like the way it now sounds/feels. That Turbo really screams. i really want to see how it performs with my 10,000 lb trailer.

So what do I need next DV's and injectors ??

96 Dodge Ram 2500, ATI intake-exhaust,S300 Turbo, 4" exaust , AFE Stage 2 ,Gsk, Custom Plate (Don't know the number, but the truck is fast) , Full Monte DTT, mag hitec pan and diff cover, Snow's stage III water injection, amsoil dual-bypass, filter engineering coolant filter, Dipricol guages (Pyro,boost,trans temp,differential temp,water temp, oil temp,). Amsoil throughout

Tows my Weekend Warrior 32' Toy hauler loaded with 3 quads.
albacore44 is offline  
post #5 of 7 (permalink) Old 08-16-2006, 06:32 PM Thread Starter
Cummins Enthusiast
 
Ridemywideglide's Avatar
 
Join Date: Apr 2006
Location: CO.
Posts: 254
Thanks: 0
Thanked 1 Time in 1 Post
iTrader Score: 0 reviews
Quote:
Originally Posted by kevin1x
smoke = fun
I agree, and while I love to black-out all the granola bicyclists around here, I'm in the same boat as albacore. Bottom isn't completely gone, but there is more lag.
I'll try the plate and see if it helps. Was gonna get one for cost of shipping a couple months ago that I think was a 10, so I guess I'll dig up that info.
Is there an easy way I can find out what injectors I have and what I swapped by the numbers on them?? Google isn't the greatest resource for this it seems..

Thanks
Brad

1996 2500 CTD, Ext Cab SLT, Longbed 4x4, 5 spd, 3:55's, 285/75/16's, Marine Cam, HX35, 5x012's, Hacked AFC, 191's, Autolite EGT, Boost & Fuel Pressure guages. 418/967 on the dyno...
To view links or images in signatures your post count must be 3 or greater. You currently have 0 posts.
2005 Wideglide, 98ci, 37g's, 10:1, race heads.
Ridemywideglide is offline  
post #6 of 7 (permalink) Old 08-16-2006, 06:43 PM
Diesel Freak
 
feelmecummin's Avatar
 
Join Date: Apr 2006
Location: McDonough, GA
Posts: 616
Thanks: 6
Thanked 7 Times in 7 Posts
iTrader Score: 0 reviews
thats what happens when you go bigger with a turbo, esp. from a 9cm housing to a 14, 16 or bigger...you get lag, MNTom is right, sounds like your low boost fueling needs some tuning, get it so you dont flood it out anymore and it will light much faster at WOT, or learn to feather it to get it lit then to the floor

'14 Cruze Diesel - Fleece EFILive
'08 Corvette Z06 - Vengeance Racing H/C/I, 583 rwhp
'07 Kawasaki ZX10R - 175 rwhp
feelmecummin is offline  
post #7 of 7 (permalink) Old 08-16-2006, 07:13 PM Thread Starter
Cummins Enthusiast
 
Ridemywideglide's Avatar
 
Join Date: Apr 2006
Location: CO.
Posts: 254
Thanks: 0
Thanked 1 Time in 1 Post
iTrader Score: 0 reviews
I'm learning to feather it a bit.. Today was really the first day I been able to get it out and run it.. If I ease into it does much better. There is no stomping to the floor, I get a HUGE cloud and egt's go straight to 1200 and it feel rather unimpressive.
I get some time this weekend to try tuning it a bit.

Thanks
Brad

1996 2500 CTD, Ext Cab SLT, Longbed 4x4, 5 spd, 3:55's, 285/75/16's, Marine Cam, HX35, 5x012's, Hacked AFC, 191's, Autolite EGT, Boost & Fuel Pressure guages. 418/967 on the dyno...
To view links or images in signatures your post count must be 3 or greater. You currently have 0 posts.
2005 Wideglide, 98ci, 37g's, 10:1, race heads.
Ridemywideglide is offline  
Sponsored Links
Advertisement
 
Closed Thread

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Dodge Cummins Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome