Help needed! - Dodge Cummins Diesel Forum
94-98 Powertrain Discussion of components that are directly involved in the power production and all that is needed to get and keep the truck moving . Engine , Transmission Ect...NO ADVERTISING

 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old 11-07-2019, 05:07 PM Thread Starter
Newbie
 
Join Date: Nov 2019
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Help needed!

I’m having problems with my 95 12v I first had an issue with lots of white smoke at idle and while driving and huge amounts of black smoke. I took it to a shop and they lied and told me it was injectors said 1500 to replace I said no will do it myself. Like an idiot bought injectors before taking out the old ones and testing them myself at another shop so put new ones in same prob. So then took all injectors to a trust worthy shop and all were good. Did compression test that was good end up having slipped timing got that fixed no more white smoke. But black smoke like a 1900s freight train my truck is not stock has air dog valve springs 4000rpm gov springs 62/65/14 turbo tech turbo 4in Exhaust head studs push rods Chromoly valves roller rockers bunch of stuff. I can see 35psi of boost when getting on it but if I’m Cruising at like 30mph and get on it it will bog and puke out black smoke and not gain speed but it will pick up speed if I’m gentle on throttle from a dead stop I can’t see the car behind me when taking off. I’ve played with afc built an intercooler tester to go on turbo found some leaks on side where it inters the block fixed those still have heavy smoke they were pretty big leaks but it did nothing for the smoke. Tested again found pinhole on intake side waiting on boot to fix that. Just don’t see that tiny hole being the bad black smoke prob. Sorry for this being so long just need advise

Johnsmith31 is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 11-07-2019, 07:00 PM
Diesel Head
 
GAmes's Avatar
 
Join Date: Sep 2009
Location: Killeen, TX
Posts: 16,322
Thanks: 150
Thanked 1,761 Times in 1,545 Posts
iTrader Score: 7 reviews
What is your timing set at, which p-pump do you have and what size are your injectors? I can't make heads or tails from what you are trying to say about boost leak testing.

97 3500, 2 WD, G56, slightly bombed, 1.3 million miles. Started the second million on 8/24/13
If you are lucky enough to be in Texas, you are lucky enough.
GAmes is offline  
post #3 of 11 (permalink) Old 11-08-2019, 12:55 AM
Cummins Nut
 
Join Date: Oct 2011
Posts: 304
Thanks: 21
Thanked 17 Times in 13 Posts
iTrader Score: 0 reviews
The reason your truck is faster when you lightly step on the throttle is because you are building heat and pressure to spool the turbo. When you just lay into it and dump black smoke you are typically over fueling and putting out the heat and pressure.

To fix this you need to tune your AFC, get afc live, or learn to drive it with your foot.

This is a common problem and is what makes driving a 12v different from many other diesels with electronically controlled injection.

98 12v SC 4X4 114K Miles, A5K, SDX 5X18, 4K GSK, KDP, Custom VB, Deep Pan, Peak Diesel IC/B, Devils Own W/M, Head Studs, 60lb VS, 2095 Rack Plug, Barrels moved, Guages (EGT, Boost, Trans Temp), Timed 22* http://s1057.photobucket.com/albums/t398/lwilde13/
nSaEvAyL is offline  
Sponsored Links
Advertisement
 
post #4 of 11 (permalink) Old 11-08-2019, 09:07 AM Thread Starter
Newbie
 
Join Date: Nov 2019
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Yeah I’m not sure about the injector size I bought the truck a few months back. The thing is I’m only giving her half throttle and she falls flat and dumps smoke. Egts never go over 1000 since I got the timing done. But like I said have a small pinhole leak on a boot would that cause this. Don’t get a new boot till we Wednesday which suxs. Oh the injectors do say 260 bar. And I have a new set of DAP 75hp injectors in my console
Johnsmith31 is offline  
post #5 of 11 (permalink) Old 11-08-2019, 09:25 AM
Diesel Head
 
GAmes's Avatar
 
Join Date: Sep 2009
Location: Killeen, TX
Posts: 16,322
Thanks: 150
Thanked 1,761 Times in 1,545 Posts
iTrader Score: 7 reviews
So what is the timing set at and which injection pump do you have? The term "75hp injectors" means nothing. Injectors size is number of holes, size of holes and spray angle, i.e. 5X12 55 degrees. 260 bar doesn't denote their size. I suggest you read https://www.cumminsforum.com/forum/9...ead-first.html

97 3500, 2 WD, G56, slightly bombed, 1.3 million miles. Started the second million on 8/24/13
If you are lucky enough to be in Texas, you are lucky enough.
GAmes is offline  
post #6 of 11 (permalink) Old 11-08-2019, 09:46 AM
Diesel Freak
 
hookit's Avatar
 
Join Date: Nov 2010
Location: Riggins, Idaho
Posts: 672
Thanks: 143
Thanked 68 Times in 63 Posts
iTrader Score: 0 reviews
Does it have a plate in it?


Sent from my iPhone using Tapatalk

one owner '96 eclb dump flatbed. truck and owner are both computer illiterate.
hookit is offline  
post #7 of 11 (permalink) Old 11-08-2019, 11:28 AM Thread Starter
Newbie
 
Join Date: Nov 2019
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Yes it has a #10 plate and I’ll find out what the timing was set at. It’s a 215 ip I guess I can pull an injector to find out size but had hell getting them to seat. The extra dap injectors are 5x11 sac but that don’t help cause that not in the truck
Johnsmith31 is offline  
post #8 of 11 (permalink) Old 11-08-2019, 11:31 AM Thread Starter
Newbie
 
Join Date: Nov 2019
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
I’m at work and will have delayed reply times. And why does it put weird words I didn’t write in my reply’s.
Johnsmith31 is offline  
post #9 of 11 (permalink) Old 11-08-2019, 11:39 AM Thread Starter
Newbie
 
Join Date: Nov 2019
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Games I’ve read all beginners threads and have done a lot of work without posting anything just reading post have helped me a lot. This is the first time I have ever asked for help in a forum. Appreciate your comment and will pull number one injector later this evening
Johnsmith31 is offline  
post #10 of 11 (permalink) Old 11-08-2019, 11:48 AM
Diesel Freak
 
hookit's Avatar
 
Join Date: Nov 2010
Location: Riggins, Idaho
Posts: 672
Thanks: 143
Thanked 68 Times in 63 Posts
iTrader Score: 0 reviews
You had the timing reset and you dont know what they set it at? With the work you say thats been done to it and they pinned the timing back to stock, that could be your problem right there.


Sent from my iPhone using Tapatalk

one owner '96 eclb dump flatbed. truck and owner are both computer illiterate.
hookit is offline  
post #11 of 11 (permalink) Old 11-08-2019, 01:48 PM Thread Starter
Newbie
 
Join Date: Nov 2019
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
That’s what I’m thinking about the timing I’ve been talking with him and keep getting ahead of myself and forget to ask what he set it at. Like you said with all that stuff done stock won’t be right for it. He will bump it up no charge find that sweet spot have to fix my boot before I take it to him. I’ll figure it out
Johnsmith31 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Dodge Cummins Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome