1989 RWAL Code Scanning - Page 2 - Dodge Cummins Diesel Forum
89-93 Non-Powertrain Discussion of 1st Gen. Topics Not related to the Powertrain...NO ADVERTISING

 1Likes
Reply
 
LinkBack Thread Tools Display Modes
post #13 of 22 (permalink) Old 03-19-2019, 12:51 PM
Diesel Head
 
Bschwarzli's Avatar
 
Join Date: Nov 2008
Location: Ontario, Canada
Posts: 1,444
Thanks: 30
Thanked 318 Times in 164 Posts
iTrader Score: 0 reviews
I will also add there is 9 codes the box will spit out. 9/10 times, I have found it to be greenrot in the sensor cable that goes between frame connection and axle.

Robert


1980 Dodge W350 Crew Cab Dually, 97 12V, HX35/HT3B, 24 speed, Air ride, SRT8 interior, D80, Np205, D60F
1990 W250 24 spd, not close to stock, Super HX40, ASA intake - 2008 2500 Mega 6.7 68RFE
Bschwarzli is offline  
Sponsored Links
Advertisement
 
post #14 of 22 (permalink) Old 03-19-2019, 12:55 PM Thread Starter
Newbie
 
Join Date: Jun 2018
Location: Massachusetts
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Oh awesome thank you also, I turned the key to the on position and grounded out the single pin on the diagnostic connector and I could not get any codes to flash, it just stayed solid lit. I grounded to the glovebox light, battery terminal, and engine block, and nothing.
1989sligo is offline  
post #15 of 22 (permalink) Old 04-03-2019, 09:55 AM
Moderator
 
9297oldram's Avatar
 
Join Date: Sep 2010
Location: Huntington In.
Posts: 19,793
Thanks: 625
Thanked 2,153 Times in 2,010 Posts
iTrader Score: 0 reviews
What ever happened with this in case someone else may want a RWAL fixed?

84 K5 Blazer 97 12v, 47re with E-TransControl, Dodge Dana 60 with free spin hubs, Dana 70, B&M Mega shifter

96 F350 SC dually zf5, 4x4, 92 Cummins, THD 5x12's, THD fuel pin, THD HVLP with adjustable fuel pressure mod, WM, h1c 60/60/12cm WG wired
9297oldram is offline  
Sponsored Links
Advertisement
 
post #16 of 22 (permalink) Old 04-03-2019, 10:30 AM Thread Starter
Newbie
 
Join Date: Jun 2018
Location: Massachusetts
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
No matter what I do I cannot get the light to flash. I found the diagnostic connector and it has one pin inside. I grounded that to many different places with the key in the "run/on" position and no flashing. Every grounding point I tried was a good ground and I waited up to 5 minutes with each so I am somewhat lost on it.
1989sligo is offline  
post #17 of 22 (permalink) Old 04-03-2019, 10:34 AM
Moderator
 
9297oldram's Avatar
 
Join Date: Sep 2010
Location: Huntington In.
Posts: 19,793
Thanks: 625
Thanked 2,153 Times in 2,010 Posts
iTrader Score: 0 reviews
That's why everyone just unplugs the black box and doesn't worry about it.

84 K5 Blazer 97 12v, 47re with E-TransControl, Dodge Dana 60 with free spin hubs, Dana 70, B&M Mega shifter

96 F350 SC dually zf5, 4x4, 92 Cummins, THD 5x12's, THD fuel pin, THD HVLP with adjustable fuel pressure mod, WM, h1c 60/60/12cm WG wired
9297oldram is offline  
post #18 of 22 (permalink) Old 04-03-2019, 10:36 AM Thread Starter
Newbie
 
Join Date: Jun 2018
Location: Massachusetts
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Yeah, I know. I am going to throw a valve unit at it. Not too bad at $100 on RockAuto and redo the brakes and brake lines and bleed it really good. If the light goes off, great, if not I will concede defeat, unplug the box, and move on.
1989sligo is offline  
post #19 of 22 (permalink) Old 04-03-2019, 10:40 AM
Moderator
 
9297oldram's Avatar
 
Join Date: Sep 2010
Location: Huntington In.
Posts: 19,793
Thanks: 625
Thanked 2,153 Times in 2,010 Posts
iTrader Score: 0 reviews
When the valve goes bad that's what usually sets off the light so replacing the valve will probably shut the light off.

84 K5 Blazer 97 12v, 47re with E-TransControl, Dodge Dana 60 with free spin hubs, Dana 70, B&M Mega shifter

96 F350 SC dually zf5, 4x4, 92 Cummins, THD 5x12's, THD fuel pin, THD HVLP with adjustable fuel pressure mod, WM, h1c 60/60/12cm WG wired
9297oldram is offline  
post #20 of 22 (permalink) Old 04-03-2019, 10:44 AM Thread Starter
Newbie
 
Join Date: Jun 2018
Location: Massachusetts
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Okay great. The truck sat for 10 years before I bought it so I don't doubt that is the issue
1989sligo is offline  
post #21 of 22 (permalink) Old 04-03-2019, 10:49 AM
Moderator
 
9297oldram's Avatar
 
Join Date: Sep 2010
Location: Huntington In.
Posts: 19,793
Thanks: 625
Thanked 2,153 Times in 2,010 Posts
iTrader Score: 0 reviews
The valve is probably froze up then if it was sitting for that long.

84 K5 Blazer 97 12v, 47re with E-TransControl, Dodge Dana 60 with free spin hubs, Dana 70, B&M Mega shifter

96 F350 SC dually zf5, 4x4, 92 Cummins, THD 5x12's, THD fuel pin, THD HVLP with adjustable fuel pressure mod, WM, h1c 60/60/12cm WG wired
9297oldram is offline  
post #22 of 22 (permalink) Old 04-03-2019, 10:52 AM Thread Starter
Newbie
 
Join Date: Jun 2018
Location: Massachusetts
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
yeah that's what I am thinking/hoping. I need all new brake lines anyways so I will just do it then. I will be sure to post failure or success here.
1989sligo is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Dodge Cummins Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Po606 death code. Pic replaced code left and popped up again truck runs well Sonicdieselmonkey 98.5-02 Powertrain 1 08-03-2015 06:33 PM
po336 code. replaced crank sensor, code still there Clint3 98.5-02 Powertrain 9 04-17-2015 03:28 PM
P0341 code (06 5.9) rollincoal06 3rd Gen. Powertrain 3 12-21-2013 08:30 PM
Limp mode..but no code? monster50iii 3rd Gen. Performance Parts Discussion 2 10-12-2012 07:32 PM
HELP!! Getting code after putting DPF back on Rockrunner Colorado 15 07-02-2011 12:11 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome