2012 6.7 116,000 miles fuel problems - Dodge Cummins Diesel Forum
4th Gen Powertrain Discussion of components that are directly involved in the power production and all that is needed to get and keep the truck moving . Engine, Transmission, etc...NO ADVERTISING

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 06-24-2019, 07:53 PM Thread Starter
Newbie
 
Join Date: Dec 2018
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
2012 6.7 116,000 miles fuel problems

fully deleted. First symptom was no start. Added more fuel, thought it was lower than what the guage said, that did nothing. Did some research, spent a lot of money. Brand new cp3 pump, brand new lift pump, brand new anarchy diesel programmer. Still throwing exhaust service warning and P0255 code. I also threw a new fuel rail pressure sensor in it. It will hardly run with the injection pump regulator sensor plugged in. I have no idea what to do anymore. Any help would be amazing. Took it to a mechanic, he is puzzled also. Maybe the new cp3 pump went already? The lift pump sends plenty of fuel to the cp3. I have tried 2 different sensors in the new injection pump.

Jeotvos is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Dodge Cummins Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome