Exhaust brake issue - Dodge Cummins Diesel Forum
4th Gen Powertrain Discussion of components that are directly involved in the power production and all that is needed to get and keep the truck moving . Engine, Transmission, etc...NO ADVERTISING

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 06-24-2019, 01:55 PM Thread Starter
Newbie
 
Idafrog's Avatar
 
Join Date: Aug 2010
Posts: 39
Thanks: 0
Thanked 6 Times in 4 Posts
iTrader Score: 0 reviews
Exhaust brake issue

2011 2500 with 73,000 miles. Recently did a full EGR delete, Throttle valve delete, 5" Flo Pro exhaust, and H&S XRT Pro tuner, 3k ago. All is good and well. Pulling 36' 5th wheel toy hauler, 4 horse trailer, daily driving, whatever.

That is until yesterday. Was coming back home with 1 horse in the trailer @70mph, and let off the throttle as normal and exhaust brake worked fine until I went to get back on the throttle. Had no power and just smoked the out of the car behind me. Shut off the EB with the dash switch and all smoke quit and had just fine power again. I messed with it a few more times on the trip and sometimes it would do the same thing, but other times it worked as normal. I don't have a monitor to watch EGT's and such so no clue where that was. Trans temp, engine temp, etc were fine.

What and where do I go from here?

Thanks.


2011 2500 Mega Laramie, auto, mineral gray with shiney stuff.....
Idafrog is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 06-25-2019, 10:40 AM
ZOP
Decoder Ring Specialist
 
ZOP's Avatar
 
Join Date: Aug 2011
Location: Clinton, MT, US
Posts: 2,618
Thanks: 564
Thanked 371 Times in 327 Posts
iTrader Score: 0 reviews
So unless you replaced the VGT it sounds like your VGT is sticking. The other possibility is the exhaust pressure sensor. Both are same answer.... Clean or replace. There's no separate exhaust brake, the button just instructs the ECM to close the VGT almost completely when in braking. If the EB hasn't been used much the last section of the VGT can be caked with soot (or get rusty as happened with mine for a bit due to the truck sitting for long periods)

2011.5 6.7L HO 3500 4x4 ST Crew LB 3.73 SRW Rear 68RFE H&S MM w/ Custom Tuning, B&W+Companion
60 Gal RDS Tank/Tool PacBrake Bags

2012 Fuzion FZ305 35' Toy Hauler (no, the Ford does not pull this...)

To view links or images in signatures your post count must be 3 or greater. You currently have 0 posts.
ZOP is offline  
post #3 of 6 (permalink) Old 06-26-2019, 04:57 AM
BFD
Cummins Nut
 
BFD's Avatar
 
Join Date: Jan 2018
Location: Pueblo West Co. or Az. in the winter
Posts: 480
Thanks: 7
Thanked 40 Times in 39 Posts
iTrader Score: 0 reviews
Mine started acting up at 118 thousand miles and I got a code that indicated it was a mechanical problem. I took it apart and the hub that the vanes are attached to had a wear groove and that's where it was hanging up. I replaced the VGT with a fixed vane and inline exhaust brake and it is better in every way. Craig

2012 CCLB 4wd dually, 3.73, 68rfe, Fass, Deleted, EFI engine/trans tuning, BD IH SXE 363/80/.91 w/ebrake, 4" turbo back/51" Quiet Tone. DD and tow vehicle.
Olde too soon... Schmart too late!
BFD is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 06-26-2019, 10:58 AM Thread Starter
Newbie
 
Idafrog's Avatar
 
Join Date: Aug 2010
Posts: 39
Thanks: 0
Thanked 6 Times in 4 Posts
iTrader Score: 0 reviews
Thanks for the info folks. Going to try cleaning it and get it recalibrated and see what that does.
Hope it works as I am not in the budget for a new turbo just yet.

2011 2500 Mega Laramie, auto, mineral gray with shiney stuff.....
Idafrog is offline  
post #5 of 6 (permalink) Old 06-26-2019, 12:37 PM
Diesel Head
 
N of 60's Avatar
 
Join Date: Sep 2013
Location: Yukon Canada
Posts: 6,468
Thanks: 2,251
Thanked 881 Times in 705 Posts
iTrader Score: 1 reviews
Quote:
Originally Posted by Idafrog View Post
Thanks for the info folks. Going to try cleaning it and get it recalibrated and see what that does.
Hope it works as I am not in the budget for a new turbo just yet.
You will be in for a replacement. Trust me

2011,4wd LB/CC 2500 H&S Mini MCC by Tomeygun, BD protect 68rfe VB seperator plate enhanced stall triple disk TC, Super B 64.5/80/.91 3rd gen mani & inline EB, Arp 425s, Fass Titanium 95. Spare Mini in my closet.
To view links or images in signatures your post count must be 3 or greater. You currently have 0 posts.
High tech old school and finally lovin it.
N of 60 is offline  
post #6 of 6 (permalink) Old 07-24-2019, 11:31 PM
Newbie
 
mrbreeze's Avatar
 
Join Date: Mar 2014
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Could un plug the turbo also...my work truck was doing this on start w/out turning on eb been unhooked the last 30k sucks but it's a cheap bandaidūü§∑
mrbreeze is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Dodge Cummins Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome