P0087 when half full tank only - Dodge Cummins Diesel Forum
4th Gen Powertrain Discussion of components that are directly involved in the power production and all that is needed to get and keep the truck moving . Engine, Transmission, etc...NO ADVERTISING

 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 06-20-2019, 09:32 PM Thread Starter
avatar challenged
 
mikeshauling's Avatar
 
Join Date: Nov 2007
Location: centralia illinois
Posts: 4,673
Thanks: 1,994
Thanked 774 Times in 512 Posts
iTrader Score: 0 reviews
P0087 when half full tank only

Like the title says, i get the P0087 ( low rail pressure) but i only get it when i get below a half tank of fuel.
new filters, new fuel rail and sensors ( dealer throwing parts at it).

Dealer says all flow tests were fine. I am thinking lift pump is dirty in tank ?
I do have a 50 gallon aux tank plumbed into the main tank thats been recently emptied and checked for dirt, algea and water ( by me) and it looks really clean.

I have around 62,000 on the truck and it is all stock even the exhaust with no tuner or mods on it.
Dealer saying maybe injectors( more parts throwing at it), but it has never thrown an injector code and it runs fine. If it was injector(s) then it wouldnt run fine until i hit half a tank.

As long as i keep it half full or more , no code , no power loss. This has happened with loaded trailer and an empty trailer. Loaded when im just cruising or getting heavy footed it has thrown the code as well as empty trailer with cruise set at 65 MPH on flat ground it has thrown it. Always under half tank.

Ive changed filters 3 times at first thinking maybe fuel related but doubt thats it. I fuel at big stations and burn tons of fuel hauling wide loads so i goi through a bunch of fuel, im averaging 8.9 MPG in the 62,000 so i change filters on an earlier schedule than normal. I change at 10,000 not 15,000 due to the volume of fuel i burn.

I have searched several threads but my half tank issue is kind of a weird deal i hAve not seen related to this code.
I would appreciate any feedback or suggestions from you smart guys in here too ! LOL

Would rather not have dealer throw more parts at this because my truck in the damn shop means im not working , plus the fact the dealer monkeys are usually fools, usually !!


2018 WHITE CCLB DRW 4X4 Aisin 4.10
mikeshauling is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 06-21-2019, 09:01 AM
Cummins Fanatic
 
Join Date: Jun 2016
Posts: 151
Thanks: 13
Thanked 5 Times in 5 Posts
iTrader Score: 0 reviews
Are the tanks venting properly. Sounds like the old stuck vent problem us old guys had with cars when younger.

Sent from my Nokia 7.1 using Tapatalk

2013 RAM 2500 diesel 6.7 Bighorn Crew Shortbed 4x4 in white. As of 7/21/16 16,100 miles.
cwendel is offline  
post #3 of 9 (permalink) Old 06-21-2019, 09:23 AM
Newbie
 
Join Date: Jan 2016
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
The only experience I've had with this code (low rail pressure) was on my buddy's Duramax. Not sure how it relates to half tank of fuel though. Personally I would start by checking the pressure relief valve on rail and return rates on injectors. Is truck smoking more than you feel it should? On the Duramax it ended up being a bad cp3 pump but not sure I'd go there on yours given the mileage. I'd start with things like the lift pump, fprv, and injectors probably.
0rion is offline  
Sponsored Links
Advertisement
 
post #4 of 9 (permalink) Old 06-21-2019, 09:58 PM Thread Starter
avatar challenged
 
mikeshauling's Avatar
 
Join Date: Nov 2007
Location: centralia illinois
Posts: 4,673
Thanks: 1,994
Thanked 774 Times in 512 Posts
iTrader Score: 0 reviews
PRV is new as well as rail too, dealer replaced whole rail and sensors on it. LP and injector return rates and flow pressures all checked out fine too. Truck doesnt smoke at all , runs great, until half tank then it does the power loss with the code. I usually just clear the code with a cheap scanner and baby the throttle til i fuel up. I have left the code without clearing it so i could get to the dealer but it usually goes away after i have shut it off and start the truck a day or two later, usually.
I cant see it being the LP because why would it only happen at half tank ?

I will look at vents in the morning to make sure they look normal and nothing missing or out of place i guess.

2018 WHITE CCLB DRW 4X4 Aisin 4.10
mikeshauling is offline  
post #5 of 9 (permalink) Old 06-22-2019, 06:07 AM
Newbie
 
Join Date: Jan 2016
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
That's crazy it only does it at half tank. What about lift pump? Have they checked fuel pressures? Just thinking out loud...like maybe there's a crack in a line in the tank that gets exposed when tank gets at half allowing pressure to drop? No idea.
0rion is offline  
post #6 of 9 (permalink) Old 06-22-2019, 03:37 PM Thread Starter
avatar challenged
 
mikeshauling's Avatar
 
Join Date: Nov 2007
Location: centralia illinois
Posts: 4,673
Thanks: 1,994
Thanked 774 Times in 512 Posts
iTrader Score: 0 reviews
all pressures have been dealer checked. say they are good and within spec. im usually hauling a trailer when this happens though and because it calls for more fuel when i have a trailer on , thats when it happens. I went under a half tank yesterday as i was pulling in to unhook my trailer. Im off today and tomorrow so im going to see if it sets the code when im not with a trailer. hasnt set code yet but it doesnt take much pedal just to putt around town empty.

2018 WHITE CCLB DRW 4X4 Aisin 4.10
mikeshauling is offline  
post #7 of 9 (permalink) Old 06-22-2019, 06:48 PM
Newbie
 
Join Date: Jan 2016
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Sounds pretty similar to my buddy's duramax....his started out only doing it hauling when it was hot out. His ended up needing a new cp3.
0rion is offline  
post #8 of 9 (permalink) Old 06-23-2019, 08:48 PM
Diesel Head
 
7492's Avatar
 
Join Date: Apr 2007
Location: Monessen ,Pennsylvania
Posts: 5,662
Thanks: 443
Thanked 327 Times in 278 Posts
iTrader Score: 0 reviews
Quote:
Originally Posted by mikeshauling View Post
all pressures have been dealer checked. say they are good and within spec. im usually hauling a trailer when this happens though and because it calls for more fuel when i have a trailer on , thats when it happens. I went under a half tank yesterday as i was pulling in to unhook my trailer. Im off today and tomorrow so im going to see if it sets the code when im not with a trailer. hasnt set code yet but it doesnt take much pedal just to putt around town empty.
Try installing a temporary gauge to watch the lift pump pressure while going down the road. The dealer only tested it in the shop, correct ? FYI, my 07 did just that when I got down to just under 1/4 tank. I never left it go that far when I figured it.

17 3500 Laramie CCLB loaded, minus the stupid stuff.
2011 Durango Hemi Loaded
2020 KW T370 PX9 380HP 1250lbft @ 1400 RTO14908LL
7492 is offline  
post #9 of 9 (permalink) Old 07-28-2019, 08:44 PM
Newbie
 
07.5g56megaslab's Avatar
 
Join Date: Oct 2018
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Did you ever get this figured out my truck is doing the same thing
07.5g56megaslab is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Dodge Cummins Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome