Question about tubing if and when. - Dodge Cummins Diesel Forum
4th Gen Powertrain Discussion of components that are directly involved in the power production and all that is needed to get and keep the truck moving . Engine, Transmission, etc...NO ADVERTISING

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 02-12-2019, 05:04 PM Thread Starter
Newbie
 
Join Date: Jan 2019
Location: Brevard , North Carolina
Posts: 36
Thanks: 2
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Question about tubing if and when.

Hello, I hope I'm posting in the right section and this might be a obvious question.

I drive a 2011 6.7 3500 with 125k miles and its deleted.

My stock holset vgt turbo has gone out and I need to replace it. I've looked into 2nd gen swaps but its not something I'm wanting to go for at the moment. (Just trying to get my truck back).

That being said I was recommended the s300 replacement kit that lets me drop the new turbo right in without manifold or anything.

I'm replacing it with a 64.5/.90 size turbo that's supposed to be close to the same Set up as the stock turbo.

My question is, when I replace the old turbo with this s300 turbo, do I absolutely need tunes right out the gate or am I safely able to drive it without causing any damage before I get tunes?

The truck has an H&S tuner that doesn't work anymore. Outside of that I don't know what's been done.


I hope I didn't miss any key info and thanks a ton for any help.

-Nate

Natebrody11 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 02-15-2019, 09:32 PM
Diesel Head
 
Cacciatore's Avatar
 
Join Date: Nov 2013
Location: NW Indiana
Posts: 1,082
Thanks: 36
Thanked 157 Times in 123 Posts
iTrader Score: 0 reviews
Why doesn't the H&S work anymore? Screen dead?

You can unplug VGT and roll with the CEL

2011 2500 CCSB|Carli|5 blade 72mm|S&S 150%|S&S 12mm|Wilson Patterson 48RE|Freedom Racing Engines 6.8|CTT
2013 3500 MCSB |Carli Backcountry|Baja Designs|Stainless s465|RevMax ZeroFlex|L19|CTT
Cacciatore is offline  
post #3 of 6 (permalink) Old 02-15-2019, 09:50 PM Thread Starter
Newbie
 
Join Date: Jan 2019
Location: Brevard , North Carolina
Posts: 36
Thanks: 2
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
I tried plugging what H&S into the truck and nothing happened and then when i plugged it into a computer it beeped and flashed but i couldn't get it to do anything else.

I'm sorry but what do you mean by unplugging the vgt and running CEL?
Natebrody11 is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 02-15-2019, 09:53 PM
Diesel Head
 
Cacciatore's Avatar
 
Join Date: Nov 2013
Location: NW Indiana
Posts: 1,082
Thanks: 36
Thanked 157 Times in 123 Posts
iTrader Score: 0 reviews
How are you getting power to the H&S OBD2 or a fuse tap?

VGT is the turbo, CEL is a check engine light. You'll get one without proper tuning

2011 2500 CCSB|Carli|5 blade 72mm|S&S 150%|S&S 12mm|Wilson Patterson 48RE|Freedom Racing Engines 6.8|CTT
2013 3500 MCSB |Carli Backcountry|Baja Designs|Stainless s465|RevMax ZeroFlex|L19|CTT
Cacciatore is offline  
post #5 of 6 (permalink) Old 02-15-2019, 09:56 PM Thread Starter
Newbie
 
Join Date: Jan 2019
Location: Brevard , North Carolina
Posts: 36
Thanks: 2
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Ohhh my bad I see what you're saying now that I realize what CEL is. Thats not so bad then I was just worried that I wouldn't be able to drive the truck at all without tuning.

Also, There were wires hanging that looked like it may have fuse tapped with a so I tried it with those, and I also tried it with the OBD plug but nothing.
Natebrody11 is offline  
post #6 of 6 (permalink) Old 02-15-2019, 09:58 PM Thread Starter
Newbie
 
Join Date: Jan 2019
Location: Brevard , North Carolina
Posts: 36
Thanks: 2
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
I apologize about the misspelling there, it looks like it could have been fuse tapped after looking online and the different power options. So I tried the wires I found and then with that not working I plugged it into the OBD plug with no avail.
Natebrody11 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Dodge Cummins Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome