Aftermarket 68RFE Owners - Dodge Cummins Diesel Forum
4th Gen Powertrain Discussion of components that are directly involved in the power production and all that is needed to get and keep the truck moving . Engine, Transmission, etc...NO ADVERTISING

 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 12-08-2015, 11:26 AM Thread Starter
Cummins Enthusiast
 
STREETcummins's Avatar
 
Join Date: Aug 2014
Location: LaCrosse Wi
Posts: 290
Thanks: 98
Thanked 74 Times in 53 Posts
iTrader Score: 0 reviews
Aftermarket 68RFE Owners

Ok, so its been a few months since I got a new Revmax 550 68rfe installed on my 2014. At first went back and forth with Kory and we had to do some line pressure adjustments to get it to idle correctly, etc. Have them mostly fixed, except when i put the truck in reverse the line pressure jumps up and its almost like the truck is applying to much pressure and it wants to rev up and I have to hold the brake down pretty hard. Anybody with the same situation? Also the main question I have. Say, when you go try to do a boosted launch. I can't rev up the truck or build boost if its at a complete stop... is that normal? I have to roll into it. Let the truck creep a few feet forward in order for the RPM's/BOOST to build. its like its surges if I'm at a complete stop and falls flat on its face.

If thats not normal... Can I do some data logging and maybe get a fix?


2014 CC Cummins 6.7, BAP, RevMax 550, 4" Flo~Pro, PPEI, Edge CTS2 Insight, HPP Goodies.
STREETcummins is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 12-08-2015, 02:02 PM Thread Starter
Cummins Enthusiast
 
STREETcummins's Avatar
 
Join Date: Aug 2014
Location: LaCrosse Wi
Posts: 290
Thanks: 98
Thanked 74 Times in 53 Posts
iTrader Score: 0 reviews
Any thoughts anyone??

2014 CC Cummins 6.7, BAP, RevMax 550, 4" Flo~Pro, PPEI, Edge CTS2 Insight, HPP Goodies.
STREETcummins is offline  
post #3 of 10 (permalink) Old 12-08-2015, 02:12 PM
Cummins Fanatic
 
jlebrun_05's Avatar
 
Join Date: Oct 2011
Location: Colman, SD
Posts: 198
Thanks: 9
Thanked 14 Times in 13 Posts
iTrader Score: 0 reviews
Can't help you, mines not in yet, hopefully gettin it soon though

2011 2500, PPEI EFI csp4, Revmax550, Stainless diesel fmw467.7, s&s 60% overs, fleece powerflow 750 cp3, fass 150, sinister egr/cooler/throttle delete, sinister fuel rail plug, gdp breather, ARP, HBS level, bd steering box stabilizer
jlebrun_05 is offline  
Sponsored Links
Advertisement
 
post #4 of 10 (permalink) Old 12-10-2015, 08:15 PM
Cummins Nut
 
malibu27's Avatar
 
Join Date: Dec 2012
Location: Shenandoah Valley
Posts: 314
Thanks: 22
Thanked 59 Times in 42 Posts
iTrader Score: 0 reviews
You should post in the performance parts section


Sent from AutoGuide.com Free App

2010 lotta extras
malibu27 is offline  
post #5 of 10 (permalink) Old 12-14-2015, 12:23 PM
Diesel Freak
 
bluessmax's Avatar
 
Join Date: Jan 2011
Posts: 688
Thanks: 36
Thanked 928 Times in 352 Posts
iTrader Score: 0 reviews
Quote:
Originally Posted by STREETcummins View Post
Ok, so its been a few months since I got a new Revmax 550 68rfe installed on my 2014. At first went back and forth with Kory and we had to do some line pressure adjustments to get it to idle correctly, etc. Have them mostly fixed, except when i put the truck in reverse the line pressure jumps up and its almost like the truck is applying to much pressure and it wants to rev up and I have to hold the brake down pretty hard. Anybody with the same situation? Also the main question I have. Say, when you go try to do a boosted launch. I can't rev up the truck or build boost if its at a complete stop... is that normal? I have to roll into it. Let the truck creep a few feet forward in order for the RPM's/BOOST to build. its like its surges if I'm at a complete stop and falls flat on its face.

If thats not normal... Can I do some data logging and maybe get a fix?
Are you sure the line pressure is jumping up? If so- whats it jumping to?
bluessmax is offline  
post #6 of 10 (permalink) Old 12-15-2015, 08:23 AM Thread Starter
Cummins Enthusiast
 
STREETcummins's Avatar
 
Join Date: Aug 2014
Location: LaCrosse Wi
Posts: 290
Thanks: 98
Thanked 74 Times in 53 Posts
iTrader Score: 0 reviews
Quote:
Originally Posted by bluessmax View Post
Are you sure the line pressure is jumping up? If so- whats it jumping to?
Ya line pressure jumps to 225 if not a little over when i give it the berries. Im very stumped.

EDIT: it jumps when I'm accelerating...When i try to do a boosted launch I'm not sure. I will try on my way home tonight and see what happens. Ill report back

2014 CC Cummins 6.7, BAP, RevMax 550, 4" Flo~Pro, PPEI, Edge CTS2 Insight, HPP Goodies.
STREETcummins is offline  
post #7 of 10 (permalink) Old 12-15-2015, 04:25 PM
Cummins Fan
 
Join Date: Aug 2009
Location: Iowa
Posts: 71
Thanks: 5
Thanked 8 Times in 6 Posts
iTrader Score: 0 reviews
about 35K miles on mine and it doesn't rev up when putting it in reverse. don't really try to boosted launches so I cant speak for that.

2011 Ram 2500, deleted
5in exhaust h&s tuner
Revmax transmission
j9845 is offline  
post #8 of 10 (permalink) Old 12-19-2015, 05:51 PM
Cummins Fan
 
Join Date: Jul 2011
Posts: 74
Thanks: 0
Thanked 7 Times in 7 Posts
iTrader Score: 0 reviews
I have about 30k miles on mine. Couldn't get it to work right. Truck is parked now until I find someone who knows how to make my Revmax work properly.

2012 6.7 4X4 68RFE
stgil888 is offline  
post #9 of 10 (permalink) Old 12-19-2015, 06:19 PM
Diesel Head
 
N of 60's Avatar
 
Join Date: Sep 2013
Location: Yukon Canada
Posts: 6,476
Thanks: 2,251
Thanked 881 Times in 705 Posts
iTrader Score: 1 reviews
Quote:
Originally Posted by stgil888 View Post
I have about 30k miles on mine. Couldn't get it to work right. Truck is parked now until I find someone who knows how to make my Revmax work properly.
That must really hurt after that kind of investment. I had to do a complete relearn after my TC and valve body plate install. It's finally the way I think it should be acting. Up shifts and downshifts. Hope you get yours sorted out.

2011,4wd LB/CC 2500 H&S Mini MCC by Tomeygun, BD protect 68rfe VB seperator plate enhanced stall triple disk TC, Super B 64.5/80/.91 3rd gen mani & inline EB, Arp 425s, Fass Titanium 95. Spare Mini in my closet.
To view links or images in signatures your post count must be 3 or greater. You currently have 0 posts.
High tech old school and finally lovin it.
N of 60 is offline  
post #10 of 10 (permalink) Old 12-19-2015, 09:17 PM
Cummins Nut
 
Sly1types's Avatar
 
Join Date: Jan 2013
Posts: 404
Thanks: 385
Thanked 55 Times in 44 Posts
iTrader Score: 0 reviews
Are you turning off the traction control when launching? I don't launch it b/c I only have the valve body, but I have PPEI's revmax 225psi trans tuning and its awesome.

I have done a few 2wd/burnout, build 3psi then let the foot off the brake and floor it and it would smoke the tires till I would get out of it. I did one that was about 700ft!

When I back out of the garage/driveway I don't have to hit the gas, it will pull the truck.

2014 Ram 2500 Crew Cab Laramie 4x4
Bully Dog Gt with Pyro
PPEI EFI & RevMax Valve Body
Sly1types is offline  
Sponsored Links
Advertisement
 
Closed Thread

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Dodge Cummins Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome