Noise After New 5.9 Install - Dodge Cummins Diesel Forum
3rd Gen. Powertrain Discussion of components that are directly involved in the power production and all that is needed to get and keep the truck moving . Engine , Transmission Ect...NO ADVERTISING

 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 10-22-2019, 09:27 AM Thread Starter
Newbie
 
Join Date: Oct 2019
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Noise After New 5.9 Install

Hi all,

I did spend a lot of time reading posts trying to locate the answer before making a post, so I apologize if this is a repeat. I just recently had a Jasper 5.9 engine put into my 07 3500 and I have this very annoying noise that only happens (that I can hear) when accelerating at a normal pace. The noise will not happen when the engine is in park or neutral. I've narrowed it down to the injector pump and it sounds like a bag of marbles rattling around when there is a load on the the engine, accelerating, pulling my trailer, pressing the break while in drive and accelerating. From what I read the CP3 pump in a common rail and doesn't need to be timed, so I'm not sure. I've only put about 3k miles on the engine so far and wanted to make sure it's ok to keep driving. The mechanic pretty much gave up on trying to locate the source of the noise and said "its a Diesel, they make noise", but this is NOT a normal noise. Any help would be much appreciated, this noise is driving me insane!

Also, new injectors were also put in at the time of the engine install.

jljosey95 is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 10-22-2019, 09:38 AM
Diesel Freak
 
b.lee's Avatar
 
Join Date: May 2006
Location: Michigan
Posts: 730
Thanks: 42
Thanked 43 Times in 26 Posts
Garage
iTrader Score: 0 reviews
Sounds like injector rattle?
Does the truck have a programmer or tune on it?


2012 2500 Cummins 4x4 - Mega
Laramie, Auto, EFI Live
b.lee is offline  
post #3 of 10 (permalink) Old 10-22-2019, 09:45 AM Thread Starter
Newbie
 
Join Date: Oct 2019
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
I'm not sure what injector rattle sounds like, but I guess it could be coming from the injectors. Sounds like it's coming from the pump to me though. No, there is no programmer or tuner, everything stock.
jljosey95 is offline  
Sponsored Links
Advertisement
 
post #4 of 10 (permalink) Old 10-22-2019, 09:55 AM
TECH SPECIALIST
 
steve05ram360's Avatar
 
Join Date: Jun 2006
Posts: 10,473
Thanks: 540
Thanked 1,404 Times in 1,026 Posts
iTrader Score: 3 reviews
Welcome to Cumminsforum!

While the CP3 does not need to be timed, it can be adjusted so it is quieter... have a look at this...

https://www.cumminsforum.com/forum/3...g-results.html

I've never had to do it so no personal experience but there are several threads here discussing it.

AFE PG7 drop in filter, AFE Torque Tube, HTT 2.5 turbo, AFE e-mani, ATS Arc Flo, 50HP DDP , 424k, HPTuners, G56, 25.065 mpg, mpg threads ->https://www.cumminsforum.com/forum/3...l#post23312562
steve05ram360 is offline  
post #5 of 10 (permalink) Old 10-22-2019, 09:55 AM
TECH SPECIALIST
 
steve05ram360's Avatar
 
Join Date: Jun 2006
Posts: 10,473
Thanks: 540
Thanked 1,404 Times in 1,026 Posts
iTrader Score: 3 reviews
Also... if your new to the truck, this might be of use...

https://www.cumminsforum.com/forum/3...you-truck.html

AFE PG7 drop in filter, AFE Torque Tube, HTT 2.5 turbo, AFE e-mani, ATS Arc Flo, 50HP DDP , 424k, HPTuners, G56, 25.065 mpg, mpg threads ->https://www.cumminsforum.com/forum/3...l#post23312562
steve05ram360 is offline  
post #6 of 10 (permalink) Old 10-22-2019, 10:39 AM Thread Starter
Newbie
 
Join Date: Oct 2019
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Thank you very much. I'll have to give this a try.
jljosey95 is offline  
post #7 of 10 (permalink) Old 10-22-2019, 10:31 PM
Newbie
 
Join Date: Jan 2009
Posts: 40
Thanks: 2
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
I know what you are talking about, I had the same issue replaced the fuel pressure sensor and the rail pressure relief valve and it solved the pre ignition sound.

2006 Crew cab Laramie, Rancho 9k's, leveled, Nitto ridge grapplers 35x12.50x17, Mishimoto trans cooler, Carli end links, Thuren trackbar, 09 steering upgrade, built trans, Iron cross bumpers front & rear, Warn 12k winch, Bully dog tuner, KC flex 20 light bar.
eklarsen is offline  
post #8 of 10 (permalink) Old 10-23-2019, 03:29 PM Thread Starter
Newbie
 
Join Date: Oct 2019
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
I'll have to look into this thank you.
jljosey95 is offline  
post #9 of 10 (permalink) Old 10-23-2019, 03:47 PM
Diesel Head
 
rghavana's Avatar
 
Join Date: Dec 2011
Posts: 4,494
Thanks: 89
Thanked 580 Times in 545 Posts
iTrader Score: 0 reviews
Any codes ??

Good lift pump fuel supply??

04 QCSB HO Automatic
rghavana is offline  
post #10 of 10 (permalink) Old 10-23-2019, 04:23 PM Thread Starter
Newbie
 
Join Date: Oct 2019
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
No codes and according to the mechanics good fuel supply. The truck runs fine, it's just this annoying unusual noise that is driving me nuts. I'm taking to a different place to get another opinion.
jljosey95 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Dodge Cummins Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome