03 5.9 6speed- no power! - Dodge Cummins Diesel Forum
3rd Gen. Powertrain Discussion of components that are directly involved in the power production and all that is needed to get and keep the truck moving . Engine , Transmission Ect...NO ADVERTISING

 2Likes
  • 2 Post By cerberusiam
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 04-18-2019, 06:45 PM Thread Starter
Newbie
 
6speed3rdgen's Avatar
 
Join Date: Dec 2018
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
03 5.9 6speed- no power!

Im running into some problems with low power and not hitting full boost. Lift pumps checks out. Injector return is well below the spec. I did find the pressure relief valve leaking. Replaced it with a ATS race plug. The next day and a half the truck ran the best it ever has then it was right back to no power again. Replaced the FCA today, got a little better idle quality and smoother throttle but other then that power is sub par. Only thing i havent checked is the high pressure pump output. I did watch it with a scan tool and the desired and actual rail pressure followed within a 100 psi the whole time. Im lost i am a diesel tech so i have covered most of the basics and check a couple tsbs i have found online with no results. Thanks in advance!

6speed3rdgen is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 04-19-2019, 11:56 AM
Diesel Head
 
GRUNT 11B's Avatar
 
Join Date: Mar 2015
Location: Oregon
Posts: 4,553
Thanks: 198
Thanked 532 Times in 476 Posts
Garage
iTrader Score: 0 reviews
First, take that plug out and put a PRV back in the rail. Some basic things you can check is air filter, fuel filter, boost leaks, exhaust leaks and codes.

06 QCLB 4X4 G56, SOUTHBEND DD, FASS 150, ARP STUDS, 50HP INJECTORS, EFI, HE351 S475 COMPOUNDS, FLUIDAMPR, HAMILTON PUSHRODS & 103# SPRINGS, 624 HP 1090 TQ 01 QCLB 4X4 AUTO, WHEELS, TIRES, STEERING WHEEL, CUMMINS, BUMPERS, FUEL TANK, SEATS, ETC.
GRUNT 11B is online now  
post #3 of 6 (permalink) Old 04-19-2019, 12:10 PM Thread Starter
Newbie
 
6speed3rdgen's Avatar
 
Join Date: Dec 2018
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Why put the PRV back in? Just wondering. Also air filter is only got 4,000 miles on it. Fuel filter has been replaced. No codes either. Going to check for boost leaks today or this weekend
6speed3rdgen is offline  
Sponsored Links
Advertisement
 
post #4 of 6 (permalink) Old 04-19-2019, 12:12 PM
Diesel Head
 
cerberusiam's Avatar
 
Join Date: Mar 2006
Location: Minco OK
Posts: 14,883
Thanks: 9
Thanked 2,687 Times in 2,253 Posts
iTrader Score: 0 reviews
If your injectors are not bad now they will be after running the PRV plug for a while. Pressure spike sin a STOCK system can exceed 30k psi at times, on the older injectors that just isn't good thing.
AH64ID and utahtrapper like this.

05 QC LWB 4x4 Auto 3.73 LSD, IssproEV2's, Performance 48RE Opie TransGo , Smarty Tuned BBI Injected
cerberusiam is offline  
post #5 of 6 (permalink) Old 04-19-2019, 12:24 PM Thread Starter
Newbie
 
6speed3rdgen's Avatar
 
Join Date: Dec 2018
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Injectors only have about 3000 miles on them but i will put it back in just for peace of mind. Dont want to go through changing injectors again and i may have discovered a problem with the wastegate or masked it. Capped of the wastegate and it builds boost past 24 pounds, i know cause the wastegate is plugged it will go past and the truck seems to have its power back. Is this a known issue?
6speed3rdgen is offline  
post #6 of 6 (permalink) Old 04-21-2019, 07:17 PM Thread Starter
Newbie
 
6speed3rdgen's Avatar
 
Join Date: Dec 2018
Posts: 20
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
UPDATE; blocked off the wastegate. Truck seems to have power just driving normal but still doesn't have the same it use to if you trying to pass someone. Maybe boost leak? Turbo isssue?
6speed3rdgen is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Dodge Cummins Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
2016 Ram 2500 Center Console 'Power Outlet' (cigar lighter) not getting 12v power. RennieRam2500 4th Gen Non-Cummins Powered RAM General Discussion 0 03-11-2019 11:13 PM
Thumbs Down on Calibrated Power or lack there of SIXTYCYCLE 4th Gen Performance Parts Discussion 30 05-30-2018 09:19 AM
Upgraded Tranny Fluid - Power Big Blue24 94-98 Performance Parts Discussion 21 11-21-2015 08:47 PM
Engine codes brihvac 2013-2018 General Discussion 18 03-28-2014 12:57 PM
Fuel Requirements For Cummins Engines - Service Bulletin 3379001 LReiff Technical Service Bulletins & Recall Support 9 11-17-2012 02:48 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome