Dodge Cummins Diesel Forum - View Single Post - Fan Clutch Not Working?
View Single Post
post #35 of (permalink) Old 08-07-2019, 08:19 PM Thread Starter
MDSWA
Diesel Head
 
MDSWA's Avatar
 
Join Date: Oct 2017
Location: NE Washington
Posts: 1,218
Thanks: 46
Thanked 132 Times in 130 Posts
So here's the resolution on my fan clutch issue:

Parts came in so today I took the truck over to a friends Class 8 shop and he installed the new fan clutch. I'm glad I took it over since it took an air hammer with an extension and a thin 36mm fan clutch stubby wrench to get the old one off. Replacement took a little less than an hour. I went with a Hayden 3282 fan clutch after reading a bunch of reviews. Hope this thing lasts! Started the truck, turned on the AC and revved the engine a little. Fan clutch fully engaged and made a definite roaring sound. The sound is unmistakable. If you're not sure if yours is working, it probably isn't.

I took the truck for a drive afterwards and kept track of temps and fan engagement. It just so happened that today is the hottest day of the year so far (102 degrees F.) I ran some errands and drove home in stop and go traffic. The fan clutch cycled on and off several times. Coolant temp peaked at 190 and trans temp hit 168 (subtract another 15 degrees from that for Edge CTS high reading error) The AC seemed to work better too. The downside? That fan is loud! At least it doesn't stay on all the time. Glad to have it working again and feeling a little better about my upcoming trip.

05 Ram 3500, SLT Bighorn, SB QC, Dynamic Stage 3 48RE, triple disc, billet input, S&B CAI, FASS Titanium, Smarty Jr., New stock Bosch injectors, Edge CTS, Hushpower/Magnaflow 4 inch, FTE Resonator, Bilstein 5100's, Redhead Steering, Truxedo, Linex
MDSWA is offline  
The Following User Says Thank You to MDSWA For This Useful Post:
tryNto (08-21-2019)
 
 
For the best viewing experience please update your browser to Google Chrome