Dodge Cummins Diesel Forum - View Single Post - Strange Trailer Light Problem
View Single Post
post #3 of (permalink) Old 04-29-2019, 03:54 PM Thread Starter
smeek
Newbie
 
Join Date: Apr 2019
Posts: 21
Thanks: 2
Thanked 1 Time in 1 Post
Quote:
Originally Posted by MDSWA View Post
Here's a link to the Newbies Guide for your new truck. It contains a Factory Service Manual that may help your to troubleshoot your electrical issues.



Have you tested all functions on the 7 pin plug with a test light to make sure everything is working on the truck? That would isolate the problem to the truck vs the trailer. Bad trailer grounds and corroded sockets, etc., can raise havoc with trailer lighting. I had a similar issue with my 05. Everything worked except the left turn signal signal on the trailer. After much troubleshooting I ended up having to replace the TIPM as it turned out to be a non-serviceable bad relay.
Thanks! That link is worth money. What a wealth of info!
I have checked the plug. The problem is within the truck. I have also seen the problem when a different trailer was connected. I have seen youtube videos where people have changed out those soldered in relays. I do electronics so that is within my skill level to do. Again all the talk that I have read about that relay being the problem refers to both the brake light and the turn signal being out. It is only the brake light on the left that is out. They both work via the same wire and pin connector in the plug.
smeek is offline  
 
 
For the best viewing experience please update your browser to Google Chrome