Serv 4wd light - Dodge Cummins Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 07-05-2019, 05:38 PM Thread Starter
Cummins Fanatic
 
Zackolas's Avatar
 
Join Date: May 2016
Location: Acton
Posts: 146
Thanks: 0
Thanked 3 Times in 3 Posts
iTrader Score: 0 reviews
Serv 4wd light

I'm just over 5k on my 19 3500 Laramie longbed and my service 4WD light came on while I was on the freeway. I don't have a scanner so I can't pull the code. I parked it turned it off. When I turned the truck back on and it was off. Next day at almost the same spot on the freeway it came back on. Same thing turned off the truck turned it back on and it was gone. Today driving through town it came back. Anyone else have an issue with their 4WD yet?

Zackolas is online now  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 07-05-2019, 05:43 PM Thread Starter
Cummins Fanatic
 
Zackolas's Avatar
 
Join Date: May 2016
Location: Acton
Posts: 146
Thanks: 0
Thanked 3 Times in 3 Posts
iTrader Score: 0 reviews
Here is a photo of the light on.
Attached Thumbnails
Click image for larger version

Name:	20190705_131824_1562359350011.jpg
Views:	42
Size:	233.7 KB
ID:	851359  
Zackolas is online now  
post #3 of 8 (permalink) Old 07-05-2019, 06:57 PM Thread Starter
Cummins Fanatic
 
Zackolas's Avatar
 
Join Date: May 2016
Location: Acton
Posts: 146
Thanks: 0
Thanked 3 Times in 3 Posts
iTrader Score: 0 reviews
Stopped at the dealer they pulled the codes. One was active for final drive the other was stored 1404E. I'm going to climb under and see if anything has a bad connection at the transfer case and check the module itself. Hopefully I find something easy other wise I'll take it to the dealer on Monday for repairs. Such a bummer in was planning on going fishing tomorrow.
Zackolas is online now  
Sponsored Links
Advertisement
 
post #4 of 8 (permalink) Old 07-05-2019, 11:35 PM
Cummins Fan
 
redyute's Avatar
 
Join Date: Jan 2017
Location: southern maryland
Posts: 73
Thanks: 2
Thanked 2 Times in 2 Posts
iTrader Score: 0 reviews
I wouldn't even bother look under the truck, I'd take it straight back to the dealer, anyhow you good to drive it and enjoy your fishing trip, just don't get stuck in the mud lol then take it in on Monday

2016 2500 bighorn black appearance
redyute is offline  
post #5 of 8 (permalink) Old 07-06-2019, 09:29 PM
Cummins Nut
 
tkd01's Avatar
 
Join Date: Feb 2011
Location: Jacksonville, FL
Posts: 369
Thanks: 1
Thanked 47 Times in 35 Posts
iTrader Score: 0 reviews
I cannot believe that RAM has not fixed the actuator problem with these 4X4 trucks yet. As I stated in previous posts, I am on my 5th Actuator and counting. Ridiculous.

2014 3500 Laramie Mega Cab 4X4, SRW, Cummins/Aisin, Black Gold, Rambox.
tkd01 is offline  
post #6 of 8 (permalink) Old 07-07-2019, 12:31 AM
Diesel Freak
 
Join Date: Apr 2016
Location: Southern California
Posts: 754
Thanks: 6
Thanked 28 Times in 27 Posts
iTrader Score: 0 reviews
Quote:
Originally Posted by tkd01 View Post
I cannot believe that RAM has not fixed the actuator problem with these 4X4 trucks yet. As I stated in previous posts, I am on my 5th Actuator and counting. Ridiculous.
If you are on ur 5th actuator I would venture to guess something is wrong with your axle causing the actuator failure.

'19 Mega Cab 3500 HO SRW 4x4
Regal2800 is offline  
The Following User Says Thank You to Regal2800 For This Useful Post:
N of 60 (07-07-2019)
post #7 of 8 (permalink) Old 07-09-2019, 04:38 PM Thread Starter
Cummins Fanatic
 
Zackolas's Avatar
 
Join Date: May 2016
Location: Acton
Posts: 146
Thanks: 0
Thanked 3 Times in 3 Posts
iTrader Score: 0 reviews
Just talked to the service writer looks like they are going to condemn my transfer case. I was hoping it was just a module or a sensor but they are saying it's the entire unit. I'm not sure how long my truck with be down or how long it will take to get a transfer case in stock. I'm super bummed out this really sucks. This is the first major repair I've ever needed on a ram truck.
Zackolas is online now  
post #8 of 8 (permalink) Old 07-16-2019, 03:52 PM
Newbie
 
chad4039's Avatar
 
Join Date: Jul 2019
Location: Texas
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
the second day I had mine the yellow light next to 2WD turned off. None of the lights would turn on and it wouldn't go to 4HI or 4LO. I parked and turned off. About an hour later I got back in and cycled from 2-4hi-4lo and turned off again. When I turned back on the light was back on 2WD and I could cycle between 4hi and 4 lo. It hasn't done it since...

2019 RAM 2500 Laramie Longhorn MegaCab Patriot Pearl Blue
chad4039 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Dodge Cummins Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome