25K miles zero codes then truck would barely... - Dodge Cummins Diesel Forum
07.5 - 09 3rd Gen 6.7L Powertrain Discussion of components that are directly involved in the power production and all that is needed to get and keep the truck moving . Engine, Transmission, etc...NO ADVERTISING

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 09-07-2011, 09:44 PM Thread Starter
Cummins Fan
 
Join Date: Jun 2010
Posts: 50
Thanks: 8
Thanked 5 Times in 5 Posts
iTrader Score: 0 reviews
25K miles zero codes then truck would barely...

Truck would idle real rough. Cycle the key a few times and would run right. No codes!! Dealer said the turbo was most likely getting stuck. They cleaned the turbo, EGR, 02, wrapped 02 with heat wrap, egr cooler valve and pressure lines on dpf. Truck no longer has the idle issue but is real sluggish/slow off the line....overhead mileage is way down too....Am I in some stupid regen or somthing?? Put 500 miles on it and still the same.....

rraulston is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 09-07-2011, 09:53 PM
Diesel Freak
 
Powder_Keg's Avatar
 
Join Date: Jun 2008
Location: Somewhere in the woods
Posts: 872
Thanks: 89
Thanked 122 Times in 70 Posts
iTrader Score: 0 reviews
Quote:
Originally Posted by rraulston View Post
Truck would idle real rough. Cycle the key a few times and would run right. No codes!! Dealer said the turbo was most likely getting stuck. They cleaned the turbo, EGR, 02, wrapped 02 with heat wrap, egr cooler valve and pressure lines on dpf. Truck no longer has the idle issue but is real sluggish/slow off the line....overhead mileage is way down too....Am I in some stupid regen or somthing?? Put 500 miles on it and still the same.....
Fill out your sig so we know what your working with. Otherwise we cant help not knowing anything.

2008 4X4 3500 QCLB, 34K, G56, 3:73's, EFI Live tuning, Mini Maxx (as gauges), S&B Intake, Full Deletes, 4" TBE, lowered back down, Carli suspension both ends, Billstien 5100's, Amp Research boards, Line X, Completely covered in Marathon Seat covers, Mossy Oak New Break Up
To view links or images in signatures your post count must be 3 or greater. You currently have 0 posts.
Quote:
Originally Posted by Powder_Keg View Post
Cheap, Fast, Reliable. You only get two of the three....
Powder_Keg is offline  
post #3 of 8 (permalink) Old 09-07-2011, 09:54 PM
Diesel Freak
 
scubieman's Avatar
 
Join Date: Mar 2011
Location: Su Fu, SD
Posts: 632
Thanks: 37
Thanked 50 Times in 41 Posts
iTrader Score: 0 reviews
Fill on sig. Change fuel filter, change air filter. If not get some gauges to read fuel pressures and boost.
scubieman is offline  
Sponsored Links
Advertisement
 
post #4 of 8 (permalink) Old 09-07-2011, 10:51 PM Thread Starter
Cummins Fan
 
Join Date: Jun 2010
Posts: 50
Thanks: 8
Thanked 5 Times in 5 Posts
iTrader Score: 0 reviews
well I saved the sig, but its not comming up. Its a 2009 6.7 bone stock auto 4x4 extra cab. All filter within the last 1000k miles. This all started after the major cleaning. Runs fine, but just not peppy anymore. Requires alot more pedal to move. Have NEVER had a code for anything!!

2009 6.7 bone stock 4x4 extra cab. J35 flash.
rraulston is offline  
post #5 of 8 (permalink) Old 09-08-2011, 08:26 AM
Diesel Head
 
diesellady's Avatar
 
Join Date: May 2007
Location: Palmdale CA
Posts: 2,215
Thanks: 4
Thanked 213 Times in 159 Posts
iTrader Score: 0 reviews
Turbo is not closing down far enough. The ring in the turbo closes to restrict exhaust flow to the fan on the turbine side of the turbo. Kind of like putting your thumb on the end of a hose to accelerate the water so you can hose off your driveway. As it accelerates the exhaust, it causes the turbo to spool much quicker on acceleration. IF the ring is stuck open too far, you will have serious turbo lag. Tell them to give you a new turbo. And have them put the star scanner on it and take it around the block. You can watch vane position as you drive.

2007 6.7 4x4 Laramie ATS 68rfe 5star, Copilot, Edge w/CTS, Atomizer, H&S 5" TB,8"Stacks,ATS Diff, 6" lift Caltracs, Dynatracs
To view links or images in signatures your post count must be 3 or greater. You currently have 0 posts.
diesellady is offline  
post #6 of 8 (permalink) Old 09-08-2011, 09:22 PM Thread Starter
Cummins Fan
 
Join Date: Jun 2010
Posts: 50
Thanks: 8
Thanked 5 Times in 5 Posts
iTrader Score: 0 reviews
can I try cleaning it myself with the port they put into the turbo??? Or can it be taken apart and manually cleaned??? I am 3 mpg less on the overhead and it no longer moves up and down like it used too......

2009 6.7 bone stock 4x4 extra cab. J35 flash.
rraulston is offline  
post #7 of 8 (permalink) Old 09-08-2011, 10:53 PM Thread Starter
Cummins Fan
 
Join Date: Jun 2010
Posts: 50
Thanks: 8
Thanked 5 Times in 5 Posts
iTrader Score: 0 reviews
"P2563 is a fault that gets set when the turbo has reduced travel due to soot build up. Despite some rumors it's not fuel system related or turbo actuator problems. It just indicates that you need to have the turbo cleaned."

Found this....if correct, maybe its not my problem. Ive never had a code......

2009 6.7 bone stock 4x4 extra cab. J35 flash.
rraulston is offline  
post #8 of 8 (permalink) Old 09-09-2011, 12:14 AM
Diesel Head
 
diesellady's Avatar
 
Join Date: May 2007
Location: Palmdale CA
Posts: 2,215
Thanks: 4
Thanked 213 Times in 159 Posts
iTrader Score: 0 reviews
Or a P2580 which is low turbine speed sensor. THis can also indicate the turbine is not spinning fast enough. The reason you would want them to warranty it out, is because the new updated turbo has a whole new casting. Works much better and spools quicker. You will like it and the good part, is you don't have a whole drilled in your turbo.
I have a theory on why they clean it instead of pulling it and replacing it. When you drop the turbo, it hits the motormount before it clears the studs from the exhaust manifold. Pain in the you know what to remove and reinstall. If you are within warranty, just make them change it out for you. especially since you have had it cleaned once and it didn't work.

Oh and hopefully they didn't reflash the computer. The do that with out permission and the newer flashes are not always good.
Good luck, and let us know what happens.

2007 6.7 4x4 Laramie ATS 68rfe 5star, Copilot, Edge w/CTS, Atomizer, H&S 5" TB,8"Stacks,ATS Diff, 6" lift Caltracs, Dynatracs
To view links or images in signatures your post count must be 3 or greater. You currently have 0 posts.
diesellady is offline  
Sponsored Links
Advertisement
 
Closed Thread

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Dodge Cummins Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome