Keyed radio power supply ? - Dodge Cummins Diesel Forum
07.5 - 09 3rd Gen 6.7 Liter General Discussion General Chit Chat About the 6.7L 3rd generation Cummins - NO ADVERTISING

 2Likes
  • 1 Post By Asfwt
  • 1 Post By Asfwt
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 01-16-2020, 05:56 PM Thread Starter
Cummins Fanatic
 
Join Date: May 2012
Posts: 103
Thanks: 9
Thanked 2 Times in 2 Posts
iTrader Score: 0 reviews
Keyed radio power supply ?

Radio not getting the power feed from the keyed switch. It has 12v constant power but not 12v from the Keyed switch. Any wizards out there that can help me troubleshoot this. Do they know which fuse itís on. Itís not identified on the fuse chart. Everything else on the truck works as far as I know.

Thanks


09 4X4 QCSB stock

Asfwt is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 01-17-2020, 10:40 AM Thread Starter
Cummins Fanatic
 
Join Date: May 2012
Posts: 103
Thanks: 9
Thanked 2 Times in 2 Posts
iTrader Score: 0 reviews
Letís see if I can come at this a different way. Anyone have a link to a wiring diagram for my truck? Yes I googled it but it was like going down a rabbit hole. Lots of links to all kinds of places but not exactly for my truck.

Thanks again,
Asfwt is offline  
post #3 of 12 (permalink) Old 01-17-2020, 11:48 AM
Diesel Freak
 
b.lee's Avatar
 
Join Date: May 2006
Location: Michigan
Posts: 747
Thanks: 42
Thanked 46 Times in 29 Posts
Garage
iTrader Score: 0 reviews
Does it have an aftermarket radio installed or stock?


2012 2500 Cummins 4x4 - Mega
Laramie, Auto, EFI Live
b.lee is offline  
Sponsored Links
Advertisement
 
post #4 of 12 (permalink) Old 01-17-2020, 12:14 PM Thread Starter
Cummins Fanatic
 
Join Date: May 2012
Posts: 103
Thanks: 9
Thanked 2 Times in 2 Posts
iTrader Score: 0 reviews
It has a pioneer aftermarket. The problem is on the truck side. I used a plug and play adapter from Crutchfield. Did not splice any wires. The factory plug from the truck side is still intact. But the white wire with orange stripe is not sending the signal to the radio to turn on.

B.lee thanks for your reply ,
Asfwt is offline  
post #5 of 12 (permalink) Old 01-17-2020, 09:35 PM
Newbie
 
Join Date: Dec 2019
Location: Colorado
Posts: 28
Thanks: 1
Thanked 1 Time in 1 Post
iTrader Score: 0 reviews
I just did this tonight. I did not wire into any fuses though. As you look at the radio, do you see some connector plugs on the driver side of the radio just plugged into the plastic, not plugged into anything? I grabbed one of those, found which one worked on the key, then cut/spliced that into the red wire of the deck. Let me know if I need to clarify any while itís fresh on my mind. It should be your red wire as the keyed wire. On the connector it will have the yellow constant wire mating with the gray/striped wire from factory side but no keyed red wire. That red wire needs to go to the red wire I was referring to that is keyed.

I hope this helps some, let me know..

2009 Ram 2500 SXT 6.7 QCLB
morphrider is offline  
post #6 of 12 (permalink) Old 01-18-2020, 07:13 AM Thread Starter
Cummins Fanatic
 
Join Date: May 2012
Posts: 103
Thanks: 9
Thanked 2 Times in 2 Posts
iTrader Score: 0 reviews
Thanks, Morphrider,
I am traveling the next few days but will check it out when I get back.
Asfwt is offline  
post #7 of 12 (permalink) Old 01-19-2020, 04:34 PM
Newbie
 
Join Date: Dec 2019
Location: Colorado
Posts: 28
Thanks: 1
Thanked 1 Time in 1 Post
iTrader Score: 0 reviews
Quote:
Originally Posted by Asfwt View Post
Thanks, Morphrider,
I am traveling the next few days but will check it out when I get back.
Let me know if you want pictures, I got back in there today to pre wire RCA cables out of the head unit for the sub and door speaker amp, Sirius satellite and microphone. Should have done it yesterday, lol. Took pics while I was in there so I knew what RCAís go where later on.

2009 Ram 2500 SXT 6.7 QCLB
morphrider is offline  
post #8 of 12 (permalink) Old 01-22-2020, 11:01 AM
Newbie
 
maltstatt's Avatar
 
Join Date: Nov 2019
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Can you please pm me or post the photos I’m having the same problem with our 08 5500
maltstatt is offline  
post #9 of 12 (permalink) Old 01-22-2020, 11:27 AM
Newbie
 
Join Date: Dec 2019
Location: Colorado
Posts: 28
Thanks: 1
Thanked 1 Time in 1 Post
iTrader Score: 0 reviews
These are not connected to anything on my truck. I think these are for the electric 4wd knob, mine is on the floor. Another thing you can do is wire in to the fuse box with a terminal spade. This was just easy for me and will never be used for what it was intended for.

Sent from my LM-G710VM using Tapatalk

2009 Ram 2500 SXT 6.7 QCLB
morphrider is offline  
post #10 of 12 (permalink) Old 01-22-2020, 11:30 AM
Newbie
 
maltstatt's Avatar
 
Join Date: Nov 2019
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Thank you!
maltstatt is offline  
post #11 of 12 (permalink) Old 01-24-2020, 10:28 AM Thread Starter
Cummins Fanatic
 
Join Date: May 2012
Posts: 103
Thanks: 9
Thanked 2 Times in 2 Posts
iTrader Score: 0 reviews
Thanks for the photos. Hope to have time next week to work on it.
morphrider likes this.
Asfwt is offline  
post #12 of 12 (permalink) Old 01-27-2020, 07:54 PM Thread Starter
Cummins Fanatic
 
Join Date: May 2012
Posts: 103
Thanks: 9
Thanked 2 Times in 2 Posts
iTrader Score: 0 reviews
So today I tried to find out why the keyed wire to the radio didnít work. But at the end i found it was most likely somewhere deep in the wire harness. So I spliced a power wire from the cigarette lighter to the radio. Problem solved.
morphrider likes this.
Asfwt is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Dodge Cummins Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome