Multiple dash lights, MIL and speedometer malfunction - Dodge Cummins Diesel Forum
07.5 - 09 3rd Gen 6.7 Liter General Discussion General Chit Chat About the 6.7L 3rd generation Cummins - NO ADVERTISING

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 05-04-2019, 02:38 PM Thread Starter
Newbie
 
Join Date: Feb 2018
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Garage
iTrader Score: 0 reviews
Multiple dash lights, MIL and speedometer malfunction

Hi all. 2008 2500 with 170,000 Miles. Egr and DPF deleted, tuned with EFI Live. Owned the truck for 3 years and operated with deletes and tunes flawlessly until last week.

Issues:
Brake dash light
Abs dash light
MIL ON: codes thrown are:
U0019 (plz help me check this. Info available online is super confusing)
U0121
P063C
P0501

Check Gauges light intermittently on
Speedometer stopped functioning
Lightning bolt light intermittently on

Recently replaced passenger side battery
Drivers battery tests fine and both charge and discharge equally.

Prior to battery replacement the batteries died overnight they no longer do this.

These lights appeared after a week of no use and prior to the new battery.

I have cleared the codes, disconnected both batteries for 24 hours, checked fuses, cleaned battery terminals, disconnected abs pump electrical and cleaned.

I am now at a loss as to where to look, what to look for, what to do. If anyone can help, I haven’t seen a post with all of these conditions so i ask for your experience and expertise.
Thanks all!

Painizreal is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 05-05-2019, 02:28 PM
Diesel Head
 
N of 60's Avatar
 
Join Date: Sep 2013
Location: Yukon Canada
Posts: 6,343
Thanks: 2,212
Thanked 870 Times in 694 Posts
iTrader Score: 1 reviews
Pull and check your cross over cable. Always change both batteries FWIW with matching.

2011,4wd LB/CC 2500 H&S Mini MCC by Tomeygun, BD protect 68rfe VB seperator plate enhanced stall triple disk TC, Super B 64.5/80/.91 3rd gen mani & inline EB, Arp 425s, Fass Titanium 95. Spare Mini in my closet.
To view links or images in signatures your post count must be 3 or greater. You currently have 0 posts.
High tech old school and finally lovin it.
N of 60 is online now  
post #3 of 8 (permalink) Old 05-07-2019, 06:43 PM
Cummins Enthusiast
 
jakeorders's Avatar
 
Join Date: Aug 2013
Posts: 261
Thanks: 22
Thanked 26 Times in 25 Posts
iTrader Score: 0 reviews
I would start on replacing the other battery and like what N of 60 said, check the cross over.. ABS Light / Brake Light on with no cruise control possible wheel sensors... Goodluck...

2008 Ram 2500 6.7L Laramie Fully Deleted,Ananchy EFI Live(CSP5) and TCM Tune,5" MBRP,Edge CTS,Carli (BJ,TB,CA,SB and Tune Fox Shocks),FS Airbags,AFE Trans/Diff covers,S&B CAI w/Scoop,Fass 150,Beans Sump,Fleece CBP,ARP 425,Bosch 65hp,Amsoil OBP,AMP Research,Redhead Box,GDP Pro WG,Banks IC/AH,Tater 63/67,BD Exh Man,
jakeorders is offline  
Sponsored Links
Advertisement
 
post #4 of 8 (permalink) Old 06-10-2019, 02:04 AM Thread Starter
Newbie
 
Join Date: Feb 2018
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Garage
iTrader Score: 0 reviews
Update:

Replaced all power wires: battery +’s crossover wire, air heater + wire, alternator wire, TIPM wire, starter wire... and disconnected any erroneous wires like plow and led lightbars

Also replaced all main ground wires and cleaned and reground most engine bay grounds.

Truck still has no speedometer and the abs, brake, and engine lights are still illuminated.

Is my tipm bad? And if so...what causes it?
Painizreal is offline  
post #5 of 8 (permalink) Old 06-11-2019, 07:35 PM Thread Starter
Newbie
 
Join Date: Feb 2018
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Garage
iTrader Score: 0 reviews
Update: i replaced everything. All power cables on both sides including crossover. batteries, all grounds in the engine bay. I disconnected all aftermarket power wires like the plow and lighting etc.

The lightning bolt light disappeared but everything else remains the same.

Abs light
Brake light
CEL on
Speedometer not working power and fuel gauges “float around” not stabile as they were.
Can this be anything other than a tipm issue? I don’t want to spend money on it if the tipm isn’t the issue. Need to be sure. Please chime in.
Painizreal is offline  
post #6 of 8 (permalink) Old 06-18-2019, 11:14 AM Thread Starter
Newbie
 
Join Date: Feb 2018
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Garage
iTrader Score: 0 reviews
Sadly with no additional help I need to bring this to the stealership. I will try and update with the results
Painizreal is offline  
post #7 of 8 (permalink) Old 06-19-2019, 04:59 PM
Cummins Enthusiast
 
jakeorders's Avatar
 
Join Date: Aug 2013
Posts: 261
Thanks: 22
Thanked 26 Times in 25 Posts
iTrader Score: 0 reviews
Quote:
Originally Posted by Painizreal View Post
Update: i replaced everything. All power cables on both sides including crossover. batteries, all grounds in the engine bay. I disconnected all aftermarket power wires like the plow and lighting etc.

The lightning bolt light disappeared but everything else remains the same.

Abs light
Brake light
CEL on
Speedometer not working power and fuel gauges “float around” not stabile as they were.
Can this be anything other than a tipm issue? I don’t want to spend money on it if the tipm isn’t the issue. Need to be sure. Please chime in.
ABS Light / Brake Light on with no cruise control possible wheel sensors... Goodluck...

2008 Ram 2500 6.7L Laramie Fully Deleted,Ananchy EFI Live(CSP5) and TCM Tune,5" MBRP,Edge CTS,Carli (BJ,TB,CA,SB and Tune Fox Shocks),FS Airbags,AFE Trans/Diff covers,S&B CAI w/Scoop,Fass 150,Beans Sump,Fleece CBP,ARP 425,Bosch 65hp,Amsoil OBP,AMP Research,Redhead Box,GDP Pro WG,Banks IC/AH,Tater 63/67,BD Exh Man,
jakeorders is offline  
post #8 of 8 (permalink) Old 07-01-2019, 07:45 PM Thread Starter
Newbie
 
Join Date: Feb 2018
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Garage
iTrader Score: 0 reviews
Final update: no dealer required I recommend if you have a laptop and elm capable obd reader to download appcar and pay the $50 for VIN access. It gives near dealer level read and write access to many dodge vehicles.

Using appcar software the truck had 2 issues:

1. Corrosion of a connection at the TIPM (caused all CAN C communications issues and codes)
2. The rear speed sensor (at the back axel) caused abs, brake light, and failed speedometer
Painizreal is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Dodge Cummins Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome