40+ PSI on hx35? - Dodge Cummins Diesel Forum
- HOME - FORUMS - GARAGE - TECH - ARTICLES - CHAT - CLASSIFIEDS - REVIEWS - VIDEOS - MEMBER MAP - STORE - INSURANCE -
- REGISTER - CALENDAR - INFO - SITE HELP - RULES - STAFF - MEMBERSHIP - ADVERTISE - CONTACT US -


Welcome to the Dodge Cummins Diesel Forum, the fastest growing Dodge Diesel Community on the internet.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us
Go Back   Dodge Cummins Diesel Forum > 2nd Gen. Dodge Cummins 98.5-02 24V Forums > 98.5-02 Powertrain
98.5-02 Powertrain Discussion of components that are directly involved in the power production and all that is needed to get and keep the truck moving . Engine , Transmission Ect..NO ADVERTISING .

CumminsForum.com is the premier Dodge Diesel Truck Forum on the internet. Registered Users do not see the above ads.

Auto Insurance

» Featured Product
Wheel & Tire Center

Closed Thread
 
LinkBack Thread Tools Display Modes
Old 02-05-2012, 12:45 AM   #1 (permalink)
Diesel Freak
 
01_Black_Cummins's Avatar
 
Join Date: Dec 2011
Location: Bowling Green, Ohio
Posts: 632
Thanks: 62
Thanked 50 Times in 39 Posts
iTrader Score: 0 reviews
40+ PSI on hx35?

Before I installed my quadzilla, I ran with a superchip, then a Smarty. I usually made 20-25 psi of boost. But is a whole new ballgame after the quadzilla. My isspro boost gauge tops out at 40 and when the needle pegs out, the Turbo still sounds like its spooling. The boost gauge on the quad went as high as 48. Does this mean my wastegate is plugged off? What psi range can the hx35 handle without grenading?
Thanks for the help,
Eric
__________________
01 QCLB 4x4|Firepunk|5"|Quadzilla|WS 7x.013's| .93 Tubes|ED 63/68/.83|110# Springs/Rods|Traction Bars|Airdog|Fire Ringed|ARP Studs|Isspro||N2O
00 QCLB 4x4NV4500 Swap|Valair|Quadzilla|Fass w/Sump|Gauges|4" Duals
01_Black_Cummins is offline   Quick reply to this message
Sponsored Links
Advertisement
 
Old 02-05-2012, 01:02 AM   #2 (permalink)
Diesel Head
 
1stgen3rdgendodge's Avatar
 
Join Date: Jun 2009
Location: Lima, OH/Wooster, OH/Carlisle, PA
Posts: 1,400
Thanks: 94
Thanked 86 Times in 83 Posts
iTrader Score: 0 reviews
Wow 48psi is pretty high. 35psi is max for the HX35. I'm assuming that your running a boost elbow. I'd try adjusting that and see if you can get that pressure lowered with that. If that doesn't help and it keeps building boost the wastegate may be frozen shut or plugged.
__________________
01 2500 QCSB 4x4 - NV4500 Swap, 3600# SD from Kenny's, Quadzilla ADR 4k, 150HP Jammer Nozzles, RSD 4" Down Pipe-5" Straight Pipe, AEM CAI, Raptor 150, Big Line Kit Tank to VP, Leveled, Recon Smoked Cab Lights (110# Springs, HD Rods, Head Studs, in the works)
1stgen3rdgendodge is offline   Quick reply to this message
Old 02-05-2012, 01:40 AM   #3 (permalink)
Diesel Freak
 
01_Black_Cummins's Avatar
 
Join Date: Dec 2011
Location: Bowling Green, Ohio
Posts: 632
Thanks: 62
Thanked 50 Times in 39 Posts
iTrader Score: 0 reviews
Yeah, I was pretty shocked to see that number too... I have not messed with the Turbo whatsoever. Not sure what the previous owner did to it. And it seems when i have the quad turned all the way up, I have all that boost and not so much power. The Turbo spools insanely fast but soon after to hits 30+, i lose most ofy top end power and it just seems like all that boost is just a waste I guess. Do you Think its out of its efficiency range? If i turn the box down to level 5 or so, I have great power in top end and the boost is synched up with the power and speed if you know what I mean.
__________________
01 QCLB 4x4|Firepunk|5"|Quadzilla|WS 7x.013's| .93 Tubes|ED 63/68/.83|110# Springs/Rods|Traction Bars|Airdog|Fire Ringed|ARP Studs|Isspro||N2O
00 QCLB 4x4NV4500 Swap|Valair|Quadzilla|Fass w/Sump|Gauges|4" Duals
01_Black_Cummins is offline   Quick reply to this message
Old 02-05-2012, 01:57 AM   #4 (permalink)
Diesel Head
 
1stgen3rdgendodge's Avatar
 
Join Date: Jun 2009
Location: Lima, OH/Wooster, OH/Carlisle, PA
Posts: 1,400
Thanks: 94
Thanked 86 Times in 83 Posts
iTrader Score: 0 reviews
Yeah anything over 35psi is out of that turbo's efficiency range and your just now blowing hot air. Thus why it feels like your losing power. Turning the box down you aren't flow as much fuel so I'm sure your pressure is down lower. So with that said things to look for are that the wastegate is hooked up. If it has a boost elbow on it try adjusting that and see if you can get that pressure down to 35psi or a little lower and if that doesn't worked I'd say it has either been plugged off or possibly it's frozen shut. Sounds more like it's just not opening up.
__________________
01 2500 QCSB 4x4 - NV4500 Swap, 3600# SD from Kenny's, Quadzilla ADR 4k, 150HP Jammer Nozzles, RSD 4" Down Pipe-5" Straight Pipe, AEM CAI, Raptor 150, Big Line Kit Tank to VP, Leveled, Recon Smoked Cab Lights (110# Springs, HD Rods, Head Studs, in the works)
1stgen3rdgendodge is offline   Quick reply to this message
Old 02-05-2012, 02:25 AM   #5 (permalink)
Diesel Head
 
mountianman69's Avatar
 
Join Date: Sep 2010
Location: The Sticks NM
Posts: 2,693
Thanks: 770
Thanked 1,184 Times in 922 Posts
iTrader Score: 3 reviews
Quote:
Originally Posted by 1stgen3rdgendodge View Post
Yeah anything over 35psi is out of that turbo's efficiency range and your just now blowing hot air. Thus why it feels like your losing power. Turning the box down you aren't flow as much fuel so I'm sure your pressure is down lower. So with that said things to look for are that the wastegate is hooked up. If it has a boost elbow on it try adjusting that and see if you can get that pressure down to 35psi or a little lower and if that doesn't worked I'd say it has either been plugged off or possibly it's frozen shut. Sounds more like it's just not opening up.
What he said


Sent from my Autoguide iPhone app
__________________
(Built by The Pit Stop) 2001 QCSB 4x4 35" Pro comps TWINS superB over S475 with CPP 7X12 SACs with lift Quad 4K Phantom2 guages AIRDOG 150(THE GOOD FITTINGS NOT THE CRAP ONES) Valair 800hp ceramic DD billet input shaft Hamilton push rods and Hamilton springs Stainless diesel twin kit (fits perfectly!!) stainless diesel adjustable waste gate And thanks to Optima 2 Brand spanking new Red tops as a truck warming gift!
Quote:
Originally Posted by DieselDon16 View Post
Im not gonna be a Bachleor silly, Im gonna marry you!!
Quote:
Originally Posted by DieselDon16 View Post
"Im Forever yoouuurrrsss, Faithfully.........Nick"
mountianman69 is offline   Quick reply to this message
Old 02-05-2012, 02:32 AM   #6 (permalink)
Diesel Freak
 
01_Black_Cummins's Avatar
 
Join Date: Dec 2011
Location: Bowling Green, Ohio
Posts: 632
Thanks: 62
Thanked 50 Times in 39 Posts
iTrader Score: 0 reviews
Would that also explain why my Turbo whistle is so loud? I've rode in many different trucks with both hx and hy35's and theirs is nothing compared to mine. I have a 4 inch straight pipe and no silencer ring with a K&N Cold air intake and filter. I get alot of compliments on how badass the Turbo sounds but I'm starting to wonder if something could possibly be wrong with it. Its only going to be on there for a little longer. 64mm coming in the near future.
__________________
01 QCLB 4x4|Firepunk|5"|Quadzilla|WS 7x.013's| .93 Tubes|ED 63/68/.83|110# Springs/Rods|Traction Bars|Airdog|Fire Ringed|ARP Studs|Isspro||N2O
00 QCLB 4x4NV4500 Swap|Valair|Quadzilla|Fass w/Sump|Gauges|4" Duals
01_Black_Cummins is offline   Quick reply to this message
Old 02-05-2012, 02:39 AM   #7 (permalink)
Diesel Head
 
mountianman69's Avatar
 
Join Date: Sep 2010
Location: The Sticks NM
Posts: 2,693
Thanks: 770
Thanked 1,184 Times in 922 Posts
iTrader Score: 3 reviews
It's the open air filter and the silencer ring Mia ours sounds crazy loud to most people because we don't have the stock air box but I am sure you being at 45 psi is making it a bit louder


Sent from my Autoguide iPhone app
__________________
(Built by The Pit Stop) 2001 QCSB 4x4 35" Pro comps TWINS superB over S475 with CPP 7X12 SACs with lift Quad 4K Phantom2 guages AIRDOG 150(THE GOOD FITTINGS NOT THE CRAP ONES) Valair 800hp ceramic DD billet input shaft Hamilton push rods and Hamilton springs Stainless diesel twin kit (fits perfectly!!) stainless diesel adjustable waste gate And thanks to Optima 2 Brand spanking new Red tops as a truck warming gift!
Quote:
Originally Posted by DieselDon16 View Post
Im not gonna be a Bachleor silly, Im gonna marry you!!
Quote:
Originally Posted by DieselDon16 View Post
"Im Forever yoouuurrrsss, Faithfully.........Nick"
mountianman69 is offline   Quick reply to this message
Old 02-05-2012, 10:14 AM   #8 (permalink)
Diesel Head
 
1stgen3rdgendodge's Avatar
 
Join Date: Jun 2009
Location: Lima, OH/Wooster, OH/Carlisle, PA
Posts: 1,400
Thanks: 94
Thanked 86 Times in 83 Posts
iTrader Score: 0 reviews
Yeah I could imagine that at 45psi that thing would be screaming!! Mine is pretty loud as well. Never use to get much sound out of the exhaust though till I ditched the stacks and put the straight pipe on.
__________________
01 2500 QCSB 4x4 - NV4500 Swap, 3600# SD from Kenny's, Quadzilla ADR 4k, 150HP Jammer Nozzles, RSD 4" Down Pipe-5" Straight Pipe, AEM CAI, Raptor 150, Big Line Kit Tank to VP, Leveled, Recon Smoked Cab Lights (110# Springs, HD Rods, Head Studs, in the works)
1stgen3rdgendodge is offline   Quick reply to this message
Old 02-05-2012, 10:16 AM   #9 (permalink)
Diesel Head
 
cumminsdog's Avatar
 
Join Date: Jan 2009
Location: Maryland
Posts: 5,129
Thanks: 591
Thanked 1,018 Times in 772 Posts
iTrader Score: 0 reviews
just an FYI, a stock boost eblow ill be completly open. there are some boost elbows that are non adjustable and look the same on the out side but they hae a very small orfice on the insde.

also once a HX35 hits arount 30-31psi they make a completly different sound then at lower pressures.
__________________
cumminsdog is offline   Quick reply to this message
Old 02-05-2012, 12:47 PM   #10 (permalink)
Diesel Freak
 
01_Black_Cummins's Avatar
 
Join Date: Dec 2011
Location: Bowling Green, Ohio
Posts: 632
Thanks: 62
Thanked 50 Times in 39 Posts
iTrader Score: 0 reviews
Quote:
Originally Posted by 1stgen3rdgendodge View Post
Yeah I could imagine that at 45psi that thing would be screaming!! Mine is pretty loud as well. Never use to get much sound out of the exhaust though till I ditched the stacks and put the straight pipe on.
The turbo whistle at 40+ is nothing compared to When I shift. All that pressure blows off and instead of making a "sighing" it makes a very loud pop. Sounds like someone's under my hood spraying an air hose.
__________________
01 QCLB 4x4|Firepunk|5"|Quadzilla|WS 7x.013's| .93 Tubes|ED 63/68/.83|110# Springs/Rods|Traction Bars|Airdog|Fire Ringed|ARP Studs|Isspro||N2O
00 QCLB 4x4NV4500 Swap|Valair|Quadzilla|Fass w/Sump|Gauges|4" Duals
01_Black_Cummins is offline   Quick reply to this message
Old 02-24-2012, 11:29 PM   #11 (permalink)
Diesel Head
 
mountianman69's Avatar
 
Join Date: Sep 2010
Location: The Sticks NM
Posts: 2,693
Thanks: 770
Thanked 1,184 Times in 922 Posts
iTrader Score: 3 reviews
Did you figure it out??


Sent from my Autoguide iPhone app
__________________
(Built by The Pit Stop) 2001 QCSB 4x4 35" Pro comps TWINS superB over S475 with CPP 7X12 SACs with lift Quad 4K Phantom2 guages AIRDOG 150(THE GOOD FITTINGS NOT THE CRAP ONES) Valair 800hp ceramic DD billet input shaft Hamilton push rods and Hamilton springs Stainless diesel twin kit (fits perfectly!!) stainless diesel adjustable waste gate And thanks to Optima 2 Brand spanking new Red tops as a truck warming gift!
Quote:
Originally Posted by DieselDon16 View Post
Im not gonna be a Bachleor silly, Im gonna marry you!!
Quote:
Originally Posted by DieselDon16 View Post
"Im Forever yoouuurrrsss, Faithfully.........Nick"
mountianman69 is offline   Quick reply to this message
Old 02-25-2012, 12:56 AM   #12 (permalink)
Diesel Head
 
cummins24vturbodiesel's Avatar
 
Join Date: Jul 2010
Location: Castleton VT
Posts: 1,102
Thanks: 19
Thanked 152 Times in 135 Posts
iTrader Score: 6 reviews
With my quad on lvl 3, I could get 36-37 lbs of the hx35. On 5, it would hit 40-42. I was goofing around one day with the chip on 7, and I punched the fuel to look up at the boost and it was pretty near 50. I havent ran my chip over 5 since.
__________________
'99 2500 ,QCLB, 2.5" s400, ppump.
www.cumminsperformanceparts.com
cummins24vturbodiesel is offline   Quick reply to this message
Sponsored Links
Advertisement
 
Closed Thread

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Dodge Cummins Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 11:15 PM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

SEO by vBSEO 3.3.2