p1690 code please help me out asap - Dodge Cummins Diesel Forum
- HOME - FORUMS - GARAGE - TECH - ARTICLES - CHAT - CLASSIFIEDS - REVIEWS - VIDEOS - MEMBER MAP - STORE - INSURANCE -
- REGISTER - CALENDAR - INFO - SITE HELP - RULES - STAFF - MEMBERSHIP - ADVERTISE - CONTACT US -


Welcome to the Dodge Cummins Diesel Forum, the fastest growing Dodge Diesel Community on the internet.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us
Go Back   Dodge Cummins Diesel Forum > 2nd Gen. Dodge Cummins 98.5-02 24V Forums > 98.5-02 Powertrain
98.5-02 Powertrain Discussion of components that are directly involved in the power production and all that is needed to get and keep the truck moving . Engine , Transmission Ect..NO ADVERTISING .

CumminsForum.com is the premier Dodge Diesel Truck Forum on the internet. Registered Users do not see the above ads.

Auto Insurance

» Featured Product
Wheel & Tire Center

Closed Thread
 
LinkBack Thread Tools Display Modes
Old 01-02-2012, 08:21 PM   #1 (permalink)
Newbie
 
01 cummins buddy's Avatar
 
Join Date: Sep 2011
Location: gladeville,TN
Posts: 40
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
p1690 code please help me out asap

i have a brand new injector pump and brand new lift pump on my 2001 dodge 2500 cummins 6 speed ho i am throwing the p1690 rough idle within the first 5 to 10 mins of when the truck is first started then rough idle goes away also brings up check engine light and my headlights surge help me please i have been told it could be my cam shaft position sensor
01 cummins buddy is offline   Quick reply to this message
Sponsored Links
Advertisement
 
Old 01-02-2012, 08:43 PM   #2 (permalink)
Ops
Diesel Head
 
Ops's Avatar
 
Join Date: Aug 2006
Location: Middle of PA
Posts: 1,258
Thanks: 29
Thanked 60 Times in 58 Posts
iTrader Score: 0 reviews
Codes? Can't diagnose anything without it..

Ops
__________________
01 QC, totaled.
Early 04, 6 speed, power everything. Stock. so far.
Ops is offline   Quick reply to this message
Old 01-02-2012, 08:47 PM   #3 (permalink)
Newbie
 
01 cummins buddy's Avatar
 
Join Date: Sep 2011
Location: gladeville,TN
Posts: 40
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
code is p1690 i have a brand new injector pump and brand new lift pump need help wat the code is so i can fix it asap rough idle check engine light and surging headlights the rough idle is only within the first 5 to 10mins of start up then goes away i been told it could be my cam shaft position sensor
01 cummins buddy is offline   Quick reply to this message
Old 01-02-2012, 08:58 PM   #4 (permalink)
Cummins Enthusiast
 
alrhoads's Avatar
 
Join Date: Dec 2011
Location: Independence mo.
Posts: 280
Thanks: 7
Thanked 14 Times in 14 Posts
iTrader Score: 1 reviews
How many posts are you going to have on this?
1690, VP-44 and CKP sensors do not agree.
__________________
2001 F250 12V cummins (in progress) auto quad cab, AD2 150, 4K governer springs, HX35, Waste gate locked, TCU stand alone tranny controller, 9'6" v-plow, salt spreader.
alrhoads is offline   Quick reply to this message
Old 01-02-2012, 09:04 PM   #5 (permalink)
Newbie
 
01 cummins buddy's Avatar
 
Join Date: Sep 2011
Location: gladeville,TN
Posts: 40
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
does that mean my brand new vp could be bad just have a bad sensor what should i do to fix the problem or what would fix the problem
01 cummins buddy is offline   Quick reply to this message
Old 01-02-2012, 09:11 PM   #6 (permalink)
Cummins Enthusiast
 
alrhoads's Avatar
 
Join Date: Dec 2011
Location: Independence mo.
Posts: 280
Thanks: 7
Thanked 14 Times in 14 Posts
iTrader Score: 1 reviews
I would start with the sensor, you can get one at your local auto parts store.
__________________
2001 F250 12V cummins (in progress) auto quad cab, AD2 150, 4K governer springs, HX35, Waste gate locked, TCU stand alone tranny controller, 9'6" v-plow, salt spreader.
alrhoads is offline   Quick reply to this message
Old 01-02-2012, 09:16 PM   #7 (permalink)
Newbie
 
01 cummins buddy's Avatar
 
Join Date: Sep 2011
Location: gladeville,TN
Posts: 40
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
so i should just start by getting and trying a new cam shaft position sensor.
01 cummins buddy is offline   Quick reply to this message
Old 01-02-2012, 09:20 PM   #8 (permalink)
Cummins Enthusiast
 
alrhoads's Avatar
 
Join Date: Dec 2011
Location: Independence mo.
Posts: 280
Thanks: 7
Thanked 14 Times in 14 Posts
iTrader Score: 1 reviews
I would test first before spending money. Moparman has a great write up on this. Or you could just go get the crank pos sensor.
__________________
2001 F250 12V cummins (in progress) auto quad cab, AD2 150, 4K governer springs, HX35, Waste gate locked, TCU stand alone tranny controller, 9'6" v-plow, salt spreader.
alrhoads is offline   Quick reply to this message
Old 01-02-2012, 11:00 PM   #9 (permalink)
Newbie
 
RFDengine2's Avatar
 
Join Date: Feb 2011
Location: Richmond,KY
Posts: 42
Thanks: 2
Thanked 6 Times in 6 Posts
iTrader Score: 0 reviews
Does sound like a bad cam sensor. Does your tach quit working? This would be a sure sign of bad cps. Headlights surging because of grid heaters cycling when first started.
__________________
01 3500 4x4 dually QC nv4500 w/ BD shortshift, Airdog II 165, Autometer guages, AFE cold air, stainless 4", Bluechip VP, CPP 125 inj.
12 2500 4x4 CCSB auto, 20x9 moto metal +18, 305/55 nitto's
RFDengine2 is offline   Quick reply to this message
Old 01-03-2012, 12:25 AM   #10 (permalink)
www.Mopar1973Man.com
 
Mopar1973Man's Avatar
 
Join Date: Feb 2006
Location: New Meadows, Idaho
Posts: 21,609
Thanks: 1,619
Thanked 3,179 Times in 2,472 Posts
iTrader Score: 0 reviews
Here some this to help ya...
Mopar1973Man's Dodge Cummins Articles - P1690 VP44 CKP Sensor Does Not Agree With ECM CKP Sensor
__________________
2002 Dodge Ram 2500 -=- 1996 Dodge Ram 1500
-=- Michael Nelson -=-

Mopar1973Man is offline   Quick reply to this message
Old 01-03-2012, 01:19 AM   #11 (permalink)
Cummins Fanatic/INJECTION PUMP TECH ADVISOR
 
Freeride202's Avatar
 
Join Date: Jan 2008
Posts: 436
Thanks: 2
Thanked 55 Times in 32 Posts
iTrader Score: 0 reviews
You might want to recheck the installation of the injection pump. Ensure that the key was aligned properly and not damaged. Also that the injection pump key was not installed backwards (arrow should point towards the pump).
Freeride202 is offline   Quick reply to this message
Old 04-30-2012, 02:33 PM   #12 (permalink)
Newbie
 
Join Date: Apr 2012
Location: vinita ok
Posts: 2
Thanks: 1
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
My truck is throwing the same code and my tack quit working... What is cps?
__________________
1999 24V Cummins
CollegeGirl is offline   Quick reply to this message
Sponsored Links
Advertisement
 
Closed Thread

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Dodge Cummins Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 04:11 PM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

SEO by vBSEO 3.3.2