1998.5 dodge 3500qc 5.9 - Dodge Cummins Diesel Forum
98.5-02 Powertrain Discussion of components that are directly involved in the power production and all that is needed to get and keep the truck moving . Engine , Transmission Ect..NO ADVERTISING .

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 18 (permalink) Old 03-19-2017, 10:58 PM Thread Starter
Newbie
 
Join Date: Mar 2017
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Red face 1998.5 dodge 3500qc 5.9

i have a code 1689 truck will start and run has dead pedal as i hear it called lol im a newbie here the check engine light is on this truck is my deceased fathers truck it was given to me to fix and drive i have ran thru the diagnostic tests for the ecm not communicating with the fpcm i have read the threads here that say the vp44 is bad or going bad it makes me wonder sing the unit will start up and run if u hit the throttle it will go to 1200 and run smooth as glass no miss or anything i have pulled the ecm tio have it tested i can get it cked for free any other help will be greatly appreciated it is a 24 valve also

angelchaser1970 is offline  
Sponsored Links
Advertisement
 
post #2 of 18 (permalink) Old 03-20-2017, 01:29 AM
Cummins Nut
 
PTSCummins's Avatar
 
Join Date: Jan 2017
Location: Lake Country, B.C.
Posts: 306
Thanks: 6
Thanked 12 Times in 12 Posts
iTrader Score: 0 reviews
Check your fuel pump relay. When that relay fails it can set 1689 and exactly what you're experiencing.

Sent from my ASUS_Z012DC using Tapatalk

1999 Ram 2500 QCLB - SO 24V in front of NV4500 and SB DD 3250. Fresh rebuild with ARP studs, 150HP F1s, Raptor 100, EJWA, pyro and soon to be compounds.
PTSCummins is online now  
post #3 of 18 (permalink) Old 03-20-2017, 01:41 AM Thread Starter
Newbie
 
Join Date: Mar 2017
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Is that the one in the fuse box or is there another relay that i do not know about
angelchaser1970 is offline  
 
post #4 of 18 (permalink) Old 03-20-2017, 11:00 AM
Cummins Nut
 
PTSCummins's Avatar
 
Join Date: Jan 2017
Location: Lake Country, B.C.
Posts: 306
Thanks: 6
Thanked 12 Times in 12 Posts
iTrader Score: 0 reviews
Yep in the fuse box. Make sure it's not failing intermittently

Sent from my ASUS_Z012DC using Tapatalk

1999 Ram 2500 QCLB - SO 24V in front of NV4500 and SB DD 3250. Fresh rebuild with ARP studs, 150HP F1s, Raptor 100, EJWA, pyro and soon to be compounds.
PTSCummins is online now  
post #5 of 18 (permalink) Old 03-20-2017, 12:19 PM
Diesel Freak
 
Monstermaker's Avatar
 
Join Date: Sep 2011
Location: Seattle
Posts: 725
Thanks: 0
Thanked 50 Times in 47 Posts
Garage
iTrader Score: 0 reviews
I think you can swap the horn relay in its place to check?
Or just throw a new one in anyway because they don't cost much.

'99 QC 4x4 Dually, Quadzilla running without wiretap, DAP 150hp VCO7x.010s, HX35, 47RE triple disc billet everything, lockup switch, 4.10s, Gear Vendors OD, Kelderman Air Ride, Alcoas, 4" pipes, BD brake, Fass Titanium 95, Hellwig sway, airbags
Monstermaker is online now  
post #6 of 18 (permalink) Old 03-20-2017, 07:22 PM Thread Starter
Newbie
 
Join Date: Mar 2017
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
i did swap them but no change but i do have a new one to throw
in anyway i talked to a injection service today and they say its the vp44 pump probably they told me 1150.00 exchange
angelchaser1970 is offline  
post #7 of 18 (permalink) Old 03-22-2017, 01:15 AM
Diesel Head
 
Join Date: Nov 2010
Location: sacramento, ca
Posts: 10,232
Thanks: 53
Thanked 909 Times in 860 Posts
iTrader Score: 0 reviews
How has it ran prior? other symptoms. Check and clean all battery terminals and harness plugs. Check apps for smooth output on pin 3 for smooth operation from about .5v at idle to about 3.8v at WOT.
Recheck of other codes.
Any wait to start light or other ecm issues?

99 2500, Quad cab, 4x4 47RE, BD pressure lock on it, small BD 90/140 chip on the VP 44 connection plug, 17" 3rd gen wheels.3.55 diffs. Ruenell front bumper and warn winch, Rancho adj shocks. 603k miles.
bigfish95971 is offline  
post #8 of 18 (permalink) Old 03-22-2017, 02:12 AM
Cummins Nut
 
PTSCummins's Avatar
 
Join Date: Jan 2017
Location: Lake Country, B.C.
Posts: 306
Thanks: 6
Thanked 12 Times in 12 Posts
iTrader Score: 0 reviews
Stupid question, but are both engine grounds connected, and the ECM ground right above the starter connected? I'd be checking that first before you drop money on a new pump

Sent from my ASUS_Z012DC using Tapatalk

1999 Ram 2500 QCLB - SO 24V in front of NV4500 and SB DD 3250. Fresh rebuild with ARP studs, 150HP F1s, Raptor 100, EJWA, pyro and soon to be compounds.
PTSCummins is online now  
post #9 of 18 (permalink) Old 03-23-2017, 11:13 PM Thread Starter
Newbie
 
Join Date: Mar 2017
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
i will be checking all the grounds this weekend its been colder n rainy since im garageless if its nice out ill be looking at it more
angelchaser1970 is offline  
post #10 of 18 (permalink) Old 03-27-2017, 10:05 PM Thread Starter
Newbie
 
Join Date: Mar 2017
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
ok update i checked the grounds found the ground wire to the fule pump relay is not getting a full ground on the 85 pole in the pd box repaired the ground but the lift pump is also not working i checked for power and with the key on only getting 8 volts did some reading found out that it only powers up for 2 seconds when u key on and when u hit the starter it powers up for 25 seconds but the lift pump when its plugged in i dont hear it make any moise or hum or anything when u key on or try to start the truck i got to that point and it started raining will mess with it more this weekend. if it is a power issue can i reroute the power to it

angelchaser1970
To view links or images in signatures your post count must be 3 or greater. You currently have 0 posts.
angelchaser1970 is offline  
post #11 of 18 (permalink) Old 03-27-2017, 10:27 PM
Diesel Head
 
Join Date: Nov 2010
Location: sacramento, ca
Posts: 10,232
Thanks: 53
Thanked 909 Times in 860 Posts
iTrader Score: 0 reviews
Does your Wait To Start Light come on immediately when you first turn the key to on?

99 2500, Quad cab, 4x4 47RE, BD pressure lock on it, small BD 90/140 chip on the VP 44 connection plug, 17" 3rd gen wheels.3.55 diffs. Ruenell front bumper and warn winch, Rancho adj shocks. 603k miles.
bigfish95971 is offline  
post #12 of 18 (permalink) Old 03-28-2017, 05:22 AM Thread Starter
Newbie
 
Join Date: Mar 2017
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Yes it does come on immediately

angelchaser1970
To view links or images in signatures your post count must be 3 or greater. You currently have 0 posts.
angelchaser1970 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Dodge Cummins Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome