1999 dodge no heat!! - Dodge Cummins Diesel Forum
- HOME - FORUMS - GARAGE - TECH - ARTICLES - CHAT - CLASSIFIEDS - REVIEWS - VIDEOS - MEMBER MAP - STORE - INSURANCE -
- REGISTER - CALENDAR - INFO - SITE HELP - RULES - STAFF - MEMBERSHIP - ADVERTISE - CONTACT US -


Welcome to the Dodge Cummins Diesel Forum, the fastest growing Dodge Diesel Community on the internet.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us
Go Back   Dodge Cummins Diesel Forum > 2nd Gen. Dodge Cummins 98.5-02 24V Forums > 98.5-02 Non-Powertrain
98.5-02 Non-Powertrain Discussion of 98-02 Topics Not related to the Powertrain...NO ADVERTISING

CumminsForum.com is the premier Dodge Diesel Truck Forum on the internet. Registered Users do not see the above ads.

Auto Insurance

» Featured Product
Wheel & Tire Center

Reply
 
LinkBack Thread Tools Display Modes
Old 11-22-2013, 02:45 PM   #1 (permalink)
Newbie
 
silverpearl99's Avatar
 
Join Date: Nov 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
1999 dodge no heat!!

I have a 99 dodge cummins I know almost everyrhing about truck. Its blows only cold air and its 20 degrees here. Ive flushed heater core nothing im stumped and it needs to be fixed!! Anyone know or had this issue on 2nd gen before I cant gwt any heat what so ever its runs right at 200 degrees all day.

Sent from AutoGuide.com Free App
silverpearl99 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-22-2013, 03:54 PM   #2 (permalink)
Diesel Head
 
Join Date: Jul 2012
Location: Nebraska
Posts: 2,887
Thanks: 321
Thanked 288 Times in 272 Posts
iTrader Score: 0 reviews
Change the heater core. Check the blend door first.
__________________
.02 Cummins HO / 6spd / 4x4 / LBQC / Edge JWA / BD / New TreadRites /200* T-Stat / Homemade HIGHIDLE /
cummins6sp5.9 is online now   Reply With Quote Quick reply to this message
Old 11-22-2013, 05:15 PM   #3 (permalink)
Newbie
 
silverpearl99's Avatar
 
Join Date: Nov 2013
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
iTrader Score: 0 reviews
Is there a way to check blend door without tearing into dash? Is it electrical or mechanical? I dont think its heater core I have a hot line and cool line usually when a cores out I thought both hoses would be engine temp "hot"?

Sent from AutoGuide.com Free App
silverpearl99 is offline   Reply With Quote Quick reply to this message
Old 11-22-2013, 08:19 PM   #4 (permalink)
Cummins Fanatic
 
cyber1satan's Avatar
 
Join Date: Dec 2011
Location: Layton, UT
Posts: 177
Thanks: 3
Thanked 29 Times in 26 Posts
iTrader Score: 0 reviews
if one heater core hose is hot and one is cold you have a plugged heater core. i would try to back flush it first but you might end up having to change it. Both hoses should be hot.
__________________
2001 2500 HO 6speed 4wd 3.54s ext cab long bed, MBRP 4in, BHAF, Edge comp, ISSPRO Fuel Pyro Boost gauges, Raptor Garbage FP, Valair Organic DD, RV275 injectors.
cyber1satan is offline   Reply With Quote Quick reply to this message
Old 11-23-2013, 08:22 AM   #5 (permalink)
Cummins Fanatic
 
Azelgin's Avatar
 
Join Date: Feb 2012
Location: S.E.Arizona
Posts: 178
Thanks: 4
Thanked 22 Times in 20 Posts
iTrader Score: 0 reviews
Quote:
Originally Posted by silverpearl99 View Post
Is there a way to check blend door without tearing into dash? Is it electrical or mechanical? I dont think its heater core I have a hot line and cool line usually when a cores out I thought both hoses would be engine temp "hot"?

Sent from AutoGuide.com Free App
The blend door is electrical. Mine is screwed up, too. I only get all hot, or, all cold. Ir was stuck in the cold position for a long time. Ok, when you live in AZ during the summer. It finally freed up when I continually switched the control from hot to cold. I only get one extreme, or, the other, but it works. It reacts slow, but it still works. It still take a lot of back and forth to get it to respond. Who knows, you might get lucky, too.
The AC guy told me it is accessable from the passenger side. Not sure he knows what he's talking about and I haven't looked, since mine started working. By the way, its been this way for about four years.
__________________
2001 4x4 QCLB, H.O. 6spd, Edge Comp, Pyro/Boost/FP gauges, MBRP 4" SS Exhaust, AFE, Bilstien 5100s, 285/70/17 Michelin LTXs, 170k miles on original VP, JEGS $90 LP
Glad this site has an "Ignore" function
Azelgin is offline   Reply With Quote Quick reply to this message
Old 11-23-2013, 08:37 AM   #6 (permalink)
Cummins Fanatic
 
turbowine's Avatar
 
Join Date: May 2006
Location: pittsburgh
Posts: 185
Thanks: 3
Thanked 13 Times in 13 Posts
iTrader Score: 0 reviews
my blend door was messed up too somebody before me changed the heater core and something elses cause they took the box out and when they put it back together the a/c evap line was hitting the blend door causing no heat
__________________
94 12v (gone but never forgotten)
01 24v reg cab 6spd, bhaf, edge ez " rusty green bean"
turbowine is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Dodge Cummins Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 01:27 PM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

SEO by vBSEO 3.3.2