Major Hydroboost problems - Dodge Cummins Diesel Forum
- HOME - FORUMS - GARAGE - TECH - ARTICLES - CHAT - CLASSIFIEDS - REVIEWS - VIDEOS - MEMBER MAP - STORE - INSURANCE -
- REGISTER - CALENDAR - INFO - SITE HELP - RULES - STAFF - MEMBERSHIP - ADVERTISE - CONTACT US -


Welcome to the Dodge Cummins Diesel Forum, the fastest growing Dodge Diesel Community on the internet.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us
Go Back   Dodge Cummins Diesel Forum > 2nd Gen. Dodge Cummins 98.5-02 24V Forums > 98.5-02 Non-Powertrain
98.5-02 Non-Powertrain Discussion of 98-02 Topics Not related to the Powertrain...NO ADVERTISING

CumminsForum.com is the premier Dodge Diesel Truck Forum on the internet. Registered Users do not see the above ads.

Auto Insurance

» Featured Product
Wheel & Tire Center

Closed Thread
 
LinkBack Thread Tools Display Modes
Old 08-17-2011, 12:07 AM   #1 (permalink)
New Mexico Chapter Vice President
 
mikeluna_17's Avatar
 
Join Date: Oct 2008
Location: Albuquerque,New Mexico
Posts: 1,533
Thanks: 45
Thanked 28 Times in 28 Posts
iTrader Score: 1 reviews
Major Hydroboost problems

Ok so my hydroboost started leaking powersteering fluid. I ordered a kit from pirate jack with new seals. I pulled the hydroboost apart and put the two new seals on. I reinstalled the hydroboost. And now when i turn the steering wheel, the brake pedal pushes down all the way on its own! I cant drive the truck because as soon as i turn the wheel. the truck brakes on its own. i took it apart again to see what is wrong, i dont see anything wrong. please help
__________________
98.5 24 valve cummins QCLB.5spd Straight Pipe..HBS 2.5" leveling kit. 35"s No silencer ring.homemade CAI
mikeluna_17 is offline   Quick reply to this message
Sponsored Links
Advertisement
 
Old 08-17-2011, 01:03 AM   #2 (permalink)
Diesel Head
 
rhagfo's Avatar
 
Join Date: Aug 2010
Location: Western Oregon
Posts: 3,023
Thanks: 168
Thanked 303 Times in 274 Posts
iTrader Score: 0 reviews
Did you reconnect all the hoses to the correct ports to the Hydroboost unit? Connecting in the wrong ports may cause reverse action.

It is assumed that you bled the power steering and Hydroboost unit.
__________________
01 2500 5.9 QCLB 4X4 5 Spd, Valair DD Organic, Power Puck, 274K miles ISSPRO Gauges FP, Pyro,& Boost. "A" Pillar, FASS DDRP-02, BIG Line Kit, 18 PSI, 3.55's, Kool Vue Tow mirrors, Bilstien 5100's, Pacbrake, Puke bottle deleted.
rhagfo is offline   Quick reply to this message
Old 08-17-2011, 09:52 AM   #3 (permalink)
New Mexico Chapter Vice President
 
mikeluna_17's Avatar
 
Join Date: Oct 2008
Location: Albuquerque,New Mexico
Posts: 1,533
Thanks: 45
Thanked 28 Times in 28 Posts
iTrader Score: 1 reviews
Quote:
Originally Posted by rhagfo View Post
Did you reconnect all the hoses to the correct ports to the Hydroboost unit? Connecting in the wrong ports may cause reverse action.

It is assumed that you bled the power steering and Hydroboost unit.
yeah i reconnected all the hoses the way they came off. and i bled the p/s and hydroboost twice. still happening
__________________
98.5 24 valve cummins QCLB.5spd Straight Pipe..HBS 2.5" leveling kit. 35"s No silencer ring.homemade CAI
mikeluna_17 is offline   Quick reply to this message
Old 08-17-2011, 10:01 AM   #4 (permalink)
Mr. Vehicle Destroyer
 
Shibbyutman's Avatar
 
Join Date: Sep 2006
Location: Superior Township, Michigan
Posts: 11,899
Thanks: 0
Thanked 1,711 Times in 1,291 Posts
iTrader Score: 7 reviews
Did you get the linkage on the balance piston back into the slot? Its really hard to explain, but there is a little fork like piece that needs to get lined back up with the actuator rod and everything and that fork can come out REALLY easy. I think it'll cause that when you turn the wheel.
__________________
Truckless, but elbow deep in Nazi cars at the moment.
Friends don't let friends buy VP trucks....
Parts for sale: Van Aken SmartBox, 03-05 Banks 6Gun, TST PMCR w/R37 remote also have another full one w/R49. RACEME 07-09 Delete Tuners
Shibbyutman is offline   Quick reply to this message
Old 08-17-2011, 10:13 AM   #5 (permalink)
www.Mopar1973Man.com
 
Mopar1973Man's Avatar
 
Join Date: Feb 2006
Location: New Meadows, Idaho
Posts: 21,579
Thanks: 1,618
Thanked 3,171 Times in 2,465 Posts
iTrader Score: 0 reviews
I spoke with him as well... There is a hitch... He never removed the unit from the truck just split while hanging on the firewall. I've never open a hydroboost... So I'm not sure if there is something out of line or fell out of place since it was hanging on the firewall.
__________________
2002 Dodge Ram 2500 -=- 1996 Dodge Ram 1500
-=- Michael Nelson -=-

Mopar1973Man is offline   Quick reply to this message
Old 08-17-2011, 10:18 AM   #6 (permalink)
Mr. Vehicle Destroyer
 
Shibbyutman's Avatar
 
Join Date: Sep 2006
Location: Superior Township, Michigan
Posts: 11,899
Thanks: 0
Thanked 1,711 Times in 1,291 Posts
iTrader Score: 7 reviews
Mike, were you the guy that was having problems with pumps blowing up about a month or two ago?
__________________
Truckless, but elbow deep in Nazi cars at the moment.
Friends don't let friends buy VP trucks....
Parts for sale: Van Aken SmartBox, 03-05 Banks 6Gun, TST PMCR w/R37 remote also have another full one w/R49. RACEME 07-09 Delete Tuners
Shibbyutman is offline   Quick reply to this message
Old 08-17-2011, 10:20 AM   #7 (permalink)
www.Mopar1973Man.com
 
Mopar1973Man's Avatar
 
Join Date: Feb 2006
Location: New Meadows, Idaho
Posts: 21,579
Thanks: 1,618
Thanked 3,171 Times in 2,465 Posts
iTrader Score: 0 reviews
Quote:
Originally Posted by Shibbyutman View Post
Mike, were you the guy that was having problems with pumps blowing up about a month or two ago?
Not me...
__________________
2002 Dodge Ram 2500 -=- 1996 Dodge Ram 1500
-=- Michael Nelson -=-

Mopar1973Man is offline   Quick reply to this message
Old 08-17-2011, 10:24 AM   #8 (permalink)
Mr. Vehicle Destroyer
 
Shibbyutman's Avatar
 
Join Date: Sep 2006
Location: Superior Township, Michigan
Posts: 11,899
Thanks: 0
Thanked 1,711 Times in 1,291 Posts
iTrader Score: 7 reviews
whoops, wrong mike (to the OP)
__________________
Truckless, but elbow deep in Nazi cars at the moment.
Friends don't let friends buy VP trucks....
Parts for sale: Van Aken SmartBox, 03-05 Banks 6Gun, TST PMCR w/R37 remote also have another full one w/R49. RACEME 07-09 Delete Tuners
Shibbyutman is offline   Quick reply to this message
Old 08-17-2011, 12:35 PM   #9 (permalink)
New Mexico Chapter Vice President
 
mikeluna_17's Avatar
 
Join Date: Oct 2008
Location: Albuquerque,New Mexico
Posts: 1,533
Thanks: 45
Thanked 28 Times in 28 Posts
iTrader Score: 1 reviews
yeah i was the one having pump problems. and i decided to take the whole hydrobooster off. i made sure the fork was holding that rod when putting back together. everything went together smooth. i put it all back just about 30 minutes ago and its still doing the same exact thing. i dont get what the problem can be. i dont have any kinked or clogged lines. my power steering pump is working great. its just when i turn the wheel the brakes push in all the way. everything in the hydroboost went in smooth. nothing out of place. i triple checked everything
__________________
98.5 24 valve cummins QCLB.5spd Straight Pipe..HBS 2.5" leveling kit. 35"s No silencer ring.homemade CAI

Last edited by mikeluna_17; 08-17-2011 at 12:42 PM.
mikeluna_17 is offline   Quick reply to this message
Old 08-17-2011, 02:00 PM   #10 (permalink)
Mr. Vehicle Destroyer
 
Shibbyutman's Avatar
 
Join Date: Sep 2006
Location: Superior Township, Michigan
Posts: 11,899
Thanks: 0
Thanked 1,711 Times in 1,291 Posts
iTrader Score: 7 reviews
Are the seals in it directional like if you put one in backwards it would let fluid in places it shouldn't be? I can't remember.
__________________
Truckless, but elbow deep in Nazi cars at the moment.
Friends don't let friends buy VP trucks....
Parts for sale: Van Aken SmartBox, 03-05 Banks 6Gun, TST PMCR w/R37 remote also have another full one w/R49. RACEME 07-09 Delete Tuners
Shibbyutman is offline   Quick reply to this message
Old 08-17-2011, 02:21 PM   #11 (permalink)
New Mexico Chapter Vice President
 
mikeluna_17's Avatar
 
Join Date: Oct 2008
Location: Albuquerque,New Mexico
Posts: 1,533
Thanks: 45
Thanked 28 Times in 28 Posts
iTrader Score: 1 reviews
i even put the old seals back on to see maybe if the new seals were making it act weird. still nothing.
__________________
98.5 24 valve cummins QCLB.5spd Straight Pipe..HBS 2.5" leveling kit. 35"s No silencer ring.homemade CAI
mikeluna_17 is offline   Quick reply to this message
Sponsored Links
Advertisement
 
Closed Thread

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Dodge Cummins Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -4. The time now is 06:09 AM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.

SEO by vBSEO 3.3.2